Yaourt no instala nada [Solucionado]

Necesitas ayuda instalando Arch Linux? pregunta aquí!
Responder
zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Yaourt no instala nada [Solucionado]

Mensaje por zx81 » 27 Jul 2015, 08:35

Hola foro.
A modo de comentario solo, he notado últimamente que yaourt no instala nada, tarde o temprano da error de algún tipo, desde no poder descargar de inicio el paquete, a cascar en la compilación e incluso llegar a congelar la máquina.
No se si so está pasando esto o solo me ocurre a mi.
Última edición por zx81 el 10 Ago 2015, 15:57, editado 1 vez en total.

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: Yaourt no instala nada

Mensaje por madek » 28 Jul 2015, 19:03

si pudieras postear el log podriamos ayudarte, ademas de probar otro otro aur helper, para ver si es falla de yaourt o de tu equipo
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: Yaourt no instala nada

Mensaje por zx81 » 29 Jul 2015, 14:24

Pongo dos ekemplos, pero tb me ha pasado con florence, ttyrec o pdftk:

Iceweasel:

Código: Seleccionar todo

make[6]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir/config/makefiles/xpidl'
make[5]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir/xpcom/xpidl'
make[5]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir/ipc/ipdl'
make[5]: No se hace nada para 'export'.
make[5]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir/dom/bindings'
make[4]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir'
/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/config/recurse.mk:36: fallo en las instrucciones para el objetivo 'export'
make[3]: *** [export] Error 2
make[3]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir'
/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/config/rules.mk:541: fallo en las instrucciones para el objetivo 'default'
make[2]: *** [default] Error 2
make[2]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/moz-objdir'
/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release/client.mk:398: fallo en las instrucciones para el objetivo 'realbuild'
make[1]: *** [realbuild] Error 2
make[1]: se sale del directorio '/tmp/yaourt-tmp-zx80/aur-iceweasel/src/mozilla-release'
client.mk:171: fallo en las instrucciones para el objetivo 'build'
make: *** [build] Error 2
==> ERROR: Se produjo un fallo en build().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar iceweasel.
==> ¿Reiniciar la compilación de iceweasel? [s/N]
==> ---------------------------------------------
==> 

Iceweasel bin

Código: Seleccionar todo

==> ERROR: Hubo fallos durante la descarga de iceweasel_38.0.1-5_amd64.deb
    Cancelando...
==> ERROR: Makepkg no ha podido compilar iceweasel-bin.
==> ¿Reiniciar la compilación de iceweasel-bin? [s/N]
==> -------------------------------------------------
==> 
Lo de probar otro otro aur helper creo que no se a que te refieres, no soy muy avanzado en el tema.
Gracias.

Avatar de Usuario
judd
Archer
Archer
Mensajes: 55
Registrado: 04 Sep 2012, 23:22
Contactar:

Re: Yaourt no instala nada

Mensaje por judd » 29 Jul 2015, 17:05

zx81 escribió: ==> ERROR: Makepkg no ha podido compilar iceweasel-bin.
==> ¿Reiniciar la compilación de iceweasel-bin? [s/N]
==> -------------------------------------------------
==> [/code]

Lo de probar otro otro aur helper creo que no se a que te refieres, no soy muy avanzado en el tema.
Gracias.
Por el error makepkg, reinstala base y base-devel

#pacman -S base base-devel

Prueba y luego comentas :?:
Mis respetos.-

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: Yaourt no instala nada

Mensaje por zx81 » 31 Jul 2015, 16:36

Pues sigue sin funcionar. Es que lo peor de todo es que me pasa en el portátil y en el sobremesa.

Lo mismo con tomb:

Código: Seleccionar todo

=> ERROR: Hubo fallos durante la descarga de Tomb-2.0.1.tar.gz
    Cancelando...
==> ERROR: Makepkg no ha podido compilar tomb.
==> ¿Reiniciar la compilación de tomb? [s/N]
==> ----------------------------------------
==> 

Avatar de Usuario
judd
Archer
Archer
Mensajes: 55
Registrado: 04 Sep 2012, 23:22
Contactar:

Re: Yaourt no instala nada

Mensaje por judd » 31 Jul 2015, 17:07

Has probado desisntalar yaourt y volver a instalar ? es raro...
Prueba que te tira:

Código: Seleccionar todo

yaourt --stats
con ese comando tira paquetes para borrar y bastante informacion, a lo mejor

Actualizar el sistema con yaourt:

Código: Seleccionar todo

yaourt -Syyu --devel --aur
Mis respetos.-

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: Yaourt no instala nada

Mensaje por zx81 » 03 Ago 2015, 08:27

El stats me tira lo siguiente:

Código: Seleccionar todo

--------------------------------------------------------------------------------
|                              Archlinux  (yaourt 1.6)                         |
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
Paquetes instalados en total:  1028
Paquetes instalados explícitamente:  227
Paquetes instalados como dependencias para ejecutar otros paquetes:  801
Paquetes desactualizados:  144
Hay 38 paquetes que no parece(n) ser usado(s) por otro paquete:
    asciidoc autoconf2.13 automoc4 bzr classpath cloog cmake compface 
    ffmpeg-compat gcc-gcj-ecj gnome-common gnome-doc-utils 
    gobject-introspection grantlee-qt4 gtk-doc gtkhtml4 imake libconfig 
    libdvbpsi libetpan libgee libmowgli libreoffice-still-es libtar libtiger 
    libwps lua-expat lua-socket php-gd python-distutils-extra python-sphinx 
    quilt run-parts udisks vte3 yasm zenity zvbi 
Paquetes a mantener: (2) pacman glibc
Paquetes a ignorar: (3) hplip hplip-plugin evince
Grupos a ignorar: (0) 

--------------------------------------------------------------------------------
Número de repositorios configurados:  4
Paquetes por repositorio (ordenados por prioridad de pacman):
    core(150), extra(782), community(79), archlinuxfr(3),  otros*(14)

    *otros son paquetes de una compilación local o de AUR, sin soporte

--------------------------------------------------------------------------------
                                                                                
Espacio teórico que ocupan los paquetes: 5808M
Espacio real que utilizan los paquetes: 5763M
Espacio utilizado en la caché por paquetes descargados (cachedir):  1,5G
Espacio utilizado en la caché por las fuentes descargadas:  0M
El comando que indicas, no lo concía y parece ser muy completo (más que pacman incluso) por lo que he podido leer. Lo pruebo y comento resultados.

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: Yaourt no instala nada

Mensaje por madek » 03 Ago 2015, 09:54

los errores que dicen "ERROR: Hubo fallos durante la descarga de..." corresponde netamente a errores de red (de la tuya o de donde se estan descargando los archivos), el error de compilacion que pusiste en el primer ejemplo, deberia solucionarse con instalar base-devel
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: Yaourt no instala nada

Mensaje por zx81 » 04 Ago 2015, 17:02

Bueno, pues todo sigue igual.

Madek, es raro lo de los errores de mi red, porque actualizo con pacman y funciona, algunas cosas yaourt me deja instalarlas, voy por la red, correo, etc y no tengo problemas.

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: Yaourt no instala nada

Mensaje por madek » 06 Ago 2015, 11:24

no necesariamente de tu red, puede ser que la red de donde se bajan las fuentes esten con problemas
para descartar puedes probar con otro aur helper, como packer
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

Avatar de Usuario
vafe
Archer
Archer
Mensajes: 43
Registrado: 03 Feb 2010, 19:17
Ubicación: Burgos

Re: Yaourt no instala nada

Mensaje por vafe » 07 Ago 2015, 11:35

Mira, no sé si tendrá que ver, pero ha habido una reestructuraciòn de aur, algo entre versiones, lo leí en inglés y no me entero mucho, y ha afectado a las actualizaciones y las instalaciones.
A mí me pasaba, y en el foro en inglés encontré un post, no le he podido recuperar, donde lo solucionaba de la siguiente manera. A mí me funciono, asesórate primero.

cd /etc/
kate yaourtrc
buscas esta línea y la descomentas, viene comentada de origen
#AURURL="https://aur4.archlinux.org"

Qué te valga para algo.

felipe

Avatar de Usuario
judd
Archer
Archer
Mensajes: 55
Registrado: 04 Sep 2012, 23:22
Contactar:

Re: Yaourt no instala nada

Mensaje por judd » 07 Ago 2015, 12:53

vafe escribió:Mira, no sé si tendrá que ver, pero ha habido una reestructuraciòn de aur, algo entre versiones, lo leí en inglés y no me entero mucho, y ha afectado a las actualizaciones y las instalaciones.
A mí me pasaba, y en el foro en inglés encontré un post, no le he podido recuperar, donde lo solucionaba de la siguiente manera. A mí me funciono, asesórate primero.

cd /etc/
kate yaourtrc
buscas esta línea y la descomentas, viene comentada de origen

#AURURL="https://aur4.archlinux.org"

Qué te valga para algo.

felipe
Hola vafe !

Puede ser que el problema provenga de ahí, ya que lo ejecute como dijistes, en XFCE, no tengo la misma linea en el fichero:

#AURURL="https://aur.archlinux.org"

tal ves el 4 de aur le traiga problemas a zx81 ?
No lo se....pero por si cuenta, lo tengo de esta forma y sin problemas de instalación con yaourt para nada, y jamás descomente la línea.-

Salu2.-
Última edición por judd el 07 Ago 2015, 14:43, editado 2 veces en total.
Mis respetos.-

Avatar de Usuario
vafe
Archer
Archer
Mensajes: 43
Registrado: 03 Feb 2010, 19:17
Ubicación: Burgos

Re: Yaourt no instala nada

Mensaje por vafe » 07 Ago 2015, 14:16

Hola Judd.
Solo decirte que yo uso KDE. Por si sirve de algo.

Avatar de Usuario
judd
Archer
Archer
Mensajes: 55
Registrado: 04 Sep 2012, 23:22
Contactar:

Re: Yaourt no instala nada

Mensaje por judd » 07 Ago 2015, 14:34

vafe escribió:Hola Judd.
Solo decirte que yo uso KDE. Por si sirve de algo.
ra bien
Hola, nuevamente !
Sí, claro que sirve, ahora bien; esta última instalación de Arch, no la construí como siempre, a mano, (ya tengo 50 años y mis ojos no son los mismos...), la instalé con la imagen de Evo/Lution, que trae el instalador AIS, a lo mejor sea por ello, que no tengo el problema de aur4 y simplemente en la linea que tu dices, sí viene por defecto aur4, en fín...solo comentario que puden servirle a los demás.

$ cd /etc/
$ mousepad yaourtrc

#AURURL="https://aur.archlinux.org"
Mis respetos.-

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: Yaourt no instala nada

Mensaje por zx81 » 10 Ago 2015, 15:56

Bueno, pues he leído que hoy ha finalizado la migración de los paquetes AUR al sistema GIT.
He probado a instalar lo que me fallaba y ya funciona.

Gracias a todos por las respuestas.

Responder