Grub me reinicia el equipo continuamente

Necesitas ayuda instalando Arch Linux? pregunta aquí!
Responder
Xanatos
Novato
Mensajes: 4
Registrado: 10 Nov 2016, 16:43

Grub me reinicia el equipo continuamente

Mensaje por Xanatos » 10 Nov 2016, 17:19

Hola a todos.

Verán, he instalado Arch en un disco duro de 8 TB y aunque grub se me instala sin error alguno, el equipo no inicia el S.O. tras el reiniciar y no consigo saber qué estoy haciendo mal.

Os cuento los pasos que estoy siguiendo, intentaré ser breve para no aburrir al personal:

- Inicio el sistema desde live cd en 64 bit ya que mi equipo es de 64 bit
- Creo un arbol de particiones sencillo usando gdisk de la siguiente forma:

Una primera particion para /boot de 100 Megas con la etiqueta EF02
Una segunda con todo el espacio restante del disco duro donde irá el sistema operativo en si.
No creo una partición para swap poque mi intención es crear la swap en un archivo dentro de la partición raiz.

- Fomateo la partición /boot como ext2 y la otra como ext4
- Monto el arbol de directorios bajo /mnt y a continuación instalo el sistema base con # pacstrap /mnt base grub
- Genero el fstab con # genfstab -U /mnt >> /mnt/etc/fstab y es aquí cuando hago el chroot para instalar grub con las siguientes órdenes:

# grub-install --target=i386-pc --recheck --debug /dev/sdx
# grub-mkconfig -o /boot/grub/grub.cfg

Termina sin error alguno por lo que salgo de chroot, desmonto el arbol de particiones bajo /mnt y reinicio el equipo ya sin el Live CD insertado.

Después de los mensajes típicos de cualquier BIOS, el sistema muestra por unos instantes "GRUB Loading" para luego reiniciarse entrando en bucle.

___________________________________

La cosa creo que va por el disco duro:

Como es de 8 TB me veo obligado a usar Partition Table (GPT) y así lo hago, es más, gdisk lo detecta como disco de gran capacidad y automáticamente me crea un sistema de particiones (O como se diga) de tipo GPT si o si.

Esto no debería ser problema pero la BIOS de mi equipo no es UEFI sino que se trata de una BIOS de las de toda la vida.

La única referencia que encuentro a montar un S.O. con estas caracteristica es en la Wiki de Arch:

https://wiki.archlinux.org/index.php/GR ... _.28GPT.29

Pero no me aclaro.

Dice:

Código: Seleccionar todo

Cree una partición de un mebibyte (+1M con fdisk o gdisk) en el disco, sin formatearla con un sistema de archivos y asignándole el tipo de partición BIOS boot (BIOS boot con fdisk, ef02 con gdisk (o bios_grub si utiliza parted)

Esta partición puede estar colocada en cualquier parte del disco, pero tiene que estar en los primeros 2 TiB.

Esta partición debe ser creada antes instalar GRUB. Cuando la partición esté lista, instale el gestor de arranque de acuerdo con las instrucciones de abajo. 

¿Crear una particion de un mebibyte?
¿Y la monto cómo /boot? No puede ser, ahí no caben todos los archivos que instala grub.

Entonces si no es como /boot ¿Cómo debo montar esa partición para poder instalar el S.O. base????

¿A caso se refiere a crear una partición de un mebibyte además de la de 100 M para /boot??? De todas formas estoy igual: ¿Cómo la monto luego para continuar con la instalación del S.O.???



Bueno, pienso que ese puede ser el problema aunque lo mismo es otra cosa.

¿Qué opinan?

Avatar de Usuario
sud_crow
Administrador
Administrador
Mensajes: 952
Registrado: 16 Abr 2005, 00:38
Ubicación: Buenos Aires - Argentina
Contactar:

Re: Grub me reinicia el equipo continuamente

Mensaje por sud_crow » 26 Nov 2016, 03:28

Buenas, la partición de 1MB es para un tema de la BIOS, no es la que debes montar como /boot y no debes montarla manualmente, lo debería hacer GRUB. Estoy hablando de memoria, ya que yo lo he hecho para un disco de 4TB, pero no lo tengo a mano para revisarlo.

Simplemente asegúrate de dejar una partición de 1MB al principio del disco, y dado que GPT permite particiones "primarias" ilimitadas, no debería causarte problemas de ningún tipo.
¿Revisaste la wiki? | ¿Usaste la función buscar del foro? | ¿Leíste las normas del foro?
Blog : | Correo+Jabber: leonardo @ archlinux-es.org

Responder