Tiempos de inicio con systemd

Para conversaciones, comentarios, opiniones o simplemente noticias que no tengan lugar en otros foros. Cualquier tipo de discusión es bienvenida aquí!
Avatar de Usuario
engelus
Archer Intermedio
Archer Intermedio
Mensajes: 94
Registrado: 14 Jun 2011, 08:54

Re: Tiempos de inicio con systemd

Mensaje por engelus » 19 Oct 2012, 17:15

Cuidado con readahead porque a veces tiene el efecto contrario, igual no creo que le haga falta activarlos ya que su sistema bootea en 9 seg o.O el mio demora casi el doble si te fijas :p jeje

Avatar de Usuario
Jristz
Archer Extremo
Archer Extremo
Mensajes: 745
Registrado: 14 Mar 2011, 20:20

Re: Tiempos de inicio con systemd

Mensaje por Jristz » 22 Oct 2012, 13:31

Código: Seleccionar todo

Startup finished in 2369ms (kernel) + 12425ms (initramfs) + 46014ms (userspace) = 60810ms
 27282ms NetworkManager.service
  3275ms upower.service
  2848ms systemd-vconsole-setup.service
  2773ms dev-hugepages.mount
  2769ms dev-mqueue.mount
  2752ms sys-kernel-debug.mount
  2742ms avahi-daemon.service
  2495ms systemd-udev-trigger.service
  2203ms systemd-remount-fs.service
  2112ms systemd-logind.service
  1384ms home.mount
  1351ms console-kit-log-system-start.service
  1298ms systemd-udevd.service
   934ms var.mount
   872ms home-pablo-Dropbox.mount
   803ms systemd-tmpfiles-setup.service
   658ms console-kit-daemon.service
   562ms udisks2.service
   506ms systemd-sysctl.service
   472ms dev-sda4.swap
   357ms systemd-readahead-replay.service
   297ms home-pablo-Proyectos.mount
   291ms var-cache-pacman.mount
   156ms tmp.mount
   111ms systemd-readahead-collect.service
    54ms boot.mount
    49ms ntpd.service
    26ms modem-manager.service
    24ms wpa_supplicant.service
    21ms proc-sys-fs-binfmt_misc.mount
    21ms systemd-user-sessions.service
     6ms sys-fs-fuse-connections.mount
yay, cada vez más lento y sin readahead tarda el doble y eso que no uso fsck al botear
System: Host: Netbook Kernel: 4.4.39-1-lts x86_64 (64 bit) Desktop: Xfce 4.12.3 Distro: Arch Linux
Machine: Device: laptop System: TOSHIBA product: Satellite C845D v: PSCB6P-002LM1
Mobo: AMD model: Renmore UEFI: Insyde v: 6.10 date: 09/14/2012
Battery[/b] BAT1: charge: 5.3 Wh 17.5% condition: 30.4/44.0 Wh (69%)
CPU: Dual core AMD E-300 APU with Radeon HD Graphics (-MCP-) speed: 1300 MHz (max)
Graphics: Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6310]

Avatar de Usuario
uny11
Novato
Mensajes: 14
Registrado: 03 Oct 2012, 08:13

Re: Tiempos de inicio con systemd

Mensaje por uny11 » 23 Oct 2012, 12:11

@zodiac
Gracias por el consejo, lo probaré. A ver que tal. Informo de cambios.

Avatar de Usuario
Drakkar
Novato
Mensajes: 8
Registrado: 24 Oct 2012, 00:34
Ubicación: Canarias

Re: Tiempos de inicio con systemd

Mensaje por Drakkar » 24 Oct 2012, 01:51

Buenas compañeros haqui posteo el mio, si tienen algun consejo para acelerar el tiempo de inicio un poquito mas, bienvenido sera . . .

Código: Seleccionar todo

Startup finished in 2787ms (kernel) + 11572ms (userspace) = 14360ms
  6371ms wicd.service
  6272ms ufw.service
  4739ms laptop-mode-tools.service
  1817ms systemd-logind.service
  1594ms console-kit-log-system-start.service
  1208ms systemd-vconsole-setup.service
   986ms systemd-udev-trigger.service
   929ms systemd-remount-fs.service
   917ms sys-kernel-debug.mount
   884ms dev-mqueue.mount
   874ms dev-hugepages.mount
   802ms systemd-udevd.service
   416ms systemd-modules-load.service
   312ms console-kit-daemon.service
   298ms udisks2.service
   225ms systemd-user-sessions.service
   203ms systemd-tmpfiles-setup.service
   124ms home.mount
   107ms boot.mount
    99ms systemd-sysctl.service
    31ms dev-sdb2.swap
    16ms tmp.mount
     3ms sys-fs-fuse-connections.mount
     0ms proc-sys-fs-binfmt_misc.mount

Fgvolonterio
Archer
Archer
Mensajes: 38
Registrado: 01 Oct 2012, 18:43
Contactar:

Re: Tiempos de inicio con systemd

Mensaje por Fgvolonterio » 29 Oct 2012, 23:27

Casi siempre oscilaba entre los 8000 y 9000ms, aunque un dia de buenas a primeras dhcpcd enloquecio y empezo a tardar ente 8000 y 9000ms en iniciar el solo :S

Código: Seleccionar todo

Startup finished in 1808ms (kernel) + 12698ms (userspace) = 14506ms
  9083ms [email protected]
  4471ms colord.service
  2001ms systemd-logind.service
  1200ms colord-sane.service
   856ms lm_sensors.service
   736ms systemd-vconsole-setup.service
   726ms systemd-binfmt.service
   697ms systemd-remount-fs.service
   629ms dev-hugepages.mount
   613ms cpupower.service
   605ms dev-mqueue.mount
   570ms sys-kernel-debug.mount
   533ms systemd-udev-trigger.service
   527ms proc-sys-fs-binfmt_misc.mount
   490ms upower.service
   451ms systemd-udevd.service
   306ms systemd-tmpfiles-setup.service
   236ms console-kit-log-system-start.service
   202ms console-kit-daemon.service
   176ms systemd-user-sessions.service
   140ms home.mount
   104ms boot.mount
    81ms udisks2.service
    37ms rtkit-daemon.service
    26ms systemd-sysctl.service
    22ms dev-sda4.swap
    17ms tmp.mount
     1ms sys-fs-fuse-connections.mount
Desktop enviroment: xfce 4.10 + conky.
http://guias-gnu-linux.foro-gratis.net/

Avatar de Usuario
Jristz
Archer Extremo
Archer Extremo
Mensajes: 745
Registrado: 14 Mar 2011, 20:20

Re: Tiempos de inicio con systemd

Mensaje por Jristz » 31 Oct 2012, 12:08

encontre que almenos para MI el readahead ens un arma que pesa mas de lo que ayuda, lo quite y ahora oscila entre 20 y 35 segs

por otra parte ahora estoy actualizando lo de systemd-logind aver que si se acorta en algo

finalmente JFS me ayuda un pelin a bajarle lacarga al systema
System: Host: Netbook Kernel: 4.4.39-1-lts x86_64 (64 bit) Desktop: Xfce 4.12.3 Distro: Arch Linux
Machine: Device: laptop System: TOSHIBA product: Satellite C845D v: PSCB6P-002LM1
Mobo: AMD model: Renmore UEFI: Insyde v: 6.10 date: 09/14/2012
Battery[/b] BAT1: charge: 5.3 Wh 17.5% condition: 30.4/44.0 Wh (69%)
CPU: Dual core AMD E-300 APU with Radeon HD Graphics (-MCP-) speed: 1300 MHz (max)
Graphics: Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6310]

Avatar de Usuario
saito
Archer Extremo
Archer Extremo
Mensajes: 337
Registrado: 30 Ene 2011, 22:37
Ubicación: Cuenca, Ecuador

Re: Tiempos de inicio con systemd

Mensaje por saito » 03 Nov 2012, 22:31

Bueno pues recien entrando a systemd y estos son mis resultados

Código: Seleccionar todo

Startup finished in 2361ms (kernel) + 12392ms (userspace) = 14753ms
  5872ms wicd.service
  2435ms systemd-logind.service
  2157ms systemd-vconsole-setup.service
   963ms systemd-remount-fs.service
   829ms dev-hugepages.mount
   813ms systemd-modules-load.service
   781ms dev-mqueue.mount
   647ms sys-kernel-debug.mount
   631ms laptop-mode.service
   460ms systemd-udev-trigger.service
   411ms systemd-udevd.service
   319ms systemd-user-sessions.service
   269ms systemd-tmpfiles-setup.service
   243ms systemd-sysctl.service
   232ms polkit.service
   171ms home.mount
   116ms dev-sda3.swap
    38ms udisks.service
    18ms sys-fs-fuse-connections.mount
    17ms tmp.mount
    13ms boot.mount
Vive GNU/Linux, en la libertad esta el inicio de la vida

Avatar de Usuario
josei
Novato
Mensajes: 3
Registrado: 03 Nov 2012, 11:46

Re: Tiempos de inicio con systemd

Mensaje por josei » 04 Nov 2012, 00:24

Aquí va el mio:

Código: Seleccionar todo

Startup finished in 3572ms (kernel) + 17555ms (userspace) = 21127ms
  8515ms mysqld.service
  7673ms wicd.service
  4342ms net-auto-wireless.service
  4020ms gdm.service
  3938ms systemd-logind.service
  2611ms httpd.service
   612ms alsa.service
   512ms systemd-udevd.service
   509ms systemd-binfmt.service
   486ms systemd-vconsole-setup.service
   457ms accounts-daemon.service
   283ms systemd-remount-fs.service
   271ms polkit.service
   266ms systemd-udev-trigger.service
   230ms dev-mqueue.mount
   228ms systemd-tmpfiles-setup.service
   226ms dev-hugepages.mount
   224ms rtkit-daemon.service
   223ms sys-kernel-debug.mount
   220ms systemd-sysctl.service
   210ms proc-sys-fs-binfmt_misc.mount
   197ms rc-local.service
   150ms colord.service
   137ms systemd-user-sessions.service
    80ms home.mount
    69ms udisks2.service
    62ms upower.service
    26ms boot.mount
    13ms tmp.mount
     3ms dev-sda6.swap
     2ms sys-fs-fuse-connections.mount
El LAMP y el Wicd son los culpables, sino no tardaria tanto :P

Avatar de Usuario
Miles
Novato
Mensajes: 10
Registrado: 27 Ago 2008, 06:52
Ubicación: Sevilla (España)

Re: Tiempos de inicio con systemd

Mensaje por Miles » 21 Nov 2012, 15:52

Código: Seleccionar todo

Startup finished in 1901ms (kernel) + 2645ms (userspace) = 4546ms
  1897ms [email protected]
   282ms media-data.mount
   133ms systemd-logind.service
   105ms systemd-udev-trigger.service
    99ms lm_sensors.service
    96ms systemd-remount-fs.service
    90ms systemd-sysctl.service
    90ms dev-hugepages.mount
    72ms systemd-modules-load.service
    66ms dev-mqueue.mount
    66ms systemd-user-sessions.service
    63ms cpupower.service
    44ms var-log.mount
    36ms polkit.service
    35ms systemd-vconsole-setup.service
    33ms sys-kernel-debug.mount
    31ms var-tmp.mount
    30ms systemd-udevd.service
    28ms udisks2.service
    17ms dev-sda4.swap
    14ms tmp.mount
    14ms upower.service
    13ms media-box.mount
    13ms systemd-tmpfiles-setup.service
     3ms sys-fs-fuse-connections.mount

Avatar de Usuario
ultimceltic
Archer Avanzado
Archer Avanzado
Mensajes: 144
Registrado: 23 Nov 2010, 21:30
Ubicación: Oaxaca, Mèxico

Re: Tiempos de inicio con systemd

Mensaje por ultimceltic » 24 Nov 2012, 12:52

Aqui esta el mio, esta dentro de lo normal me imagino:

Código: Seleccionar todo

Startup finished in 1853ms (kernel) + 11733ms (userspace) = 13586ms
  8204ms [email protected]
   826ms systemd-modules-load.service
   709ms systemd-vconsole-setup.service
   690ms systemd-logind.service
   629ms polkit.service
   547ms rtkit-daemon.service
   440ms systemd-remount-fs.service
   376ms sys-kernel-debug.mount
   342ms systemd-udev-trigger.service
   336ms dev-mqueue.mount
   309ms systemd-udevd.service
   308ms systemd-tmpfiles-setup.service
   295ms dev-hugepages.mount
   179ms home.mount
   139ms systemd-sysctl.service
   133ms systemd-user-sessions.service
   111ms ntpd.service
    75ms dev-sda4.swap
    54ms udisks2.service
    29ms boot.mount
     4ms proc-sys-fs-binfmt_misc.mount
     3ms tmp.mount
     1ms sys-fs-fuse-connections.mount

Avatar de Usuario
Ausente
Archer Avanzado
Archer Avanzado
Mensajes: 112
Registrado: 27 Jun 2009, 13:26

Re: Tiempos de inicio con systemd

Mensaje por Ausente » 25 Nov 2012, 23:05

Código: Seleccionar todo

Startup finished in 4481ms (kernel) + 12835ms (userspace) = 17317ms
  7950ms [email protected]
  7865ms network.service
  2725ms systemd-logind.service
  2156ms iptables.service
  1488ms cpupower.service
   846ms crond.service
   829ms systemd-remount-fs.service
   779ms systemd-modules-load.service
   703ms systemd-udev-trigger.service
   702ms sys-kernel-debug.mount
   679ms systemd-tmpfiles-setup.service
   673ms systemd-vconsole-setup.service
   660ms systemd-udevd.service
   653ms dev-mqueue.mount
   637ms dev-hugepages.mount
   438ms polkit.service
   288ms console-kit-log-system-start.service
   275ms upower.service
   233ms systemd-user-sessions.service
   169ms rc-local.service
   153ms systemd-sysctl.service
    87ms rtkit-daemon.service
    54ms home.mount
    43ms boot.mount
    30ms udisks.service
     4ms tmp.mount
     3ms sys-fs-fuse-connections.mount
:?

mlab
Novato
Mensajes: 11
Registrado: 01 Dic 2012, 19:44
Ubicación: Mexico

Re: Tiempos de inicio con systemd

Mensaje por mlab » 04 Dic 2012, 01:08

El mio tarda una eternidad comparándolo con los suyos, 49 segundos donde el 56% se tardan entre Wicd, mysql y apache. Nnunca escuchado eso de readahead tendre que informarme a ver si puedo hacer mas rapido esto.

Código: Seleccionar todo

Startup finished in 3597ms (kernel) + 45203ms (userspace) = 48801ms
 10765ms wicd.service
 10439ms mysqld.service
  6273ms httpd.service
  5578ms systemd-logind.service
   956ms systemd-tmpfiles-setup.service
   641ms tmp.mount
   608ms systemd-remount-fs.service
   595ms polkit.service
   577ms systemd-udevd.service
   571ms dev-hugepages.mount
   565ms dev-mqueue.mount
   564ms systemd-binfmt.service
   486ms colord.service
   408ms sys-kernel-debug.mount
   377ms systemd-user-sessions.service
   369ms systemd-sysctl.service
   345ms systemd-vconsole-setup.service
   326ms proc-sys-fs-binfmt_misc.mount
   286ms systemd-udev-trigger.service
   201ms upower.service
   185ms rtkit-daemon.service
   149ms udisks2.service
   114ms home.mount
    62ms accounts-daemon.service
    55ms dev-sda4.swap
    17ms boot.mount
Novato en Arch y a veces en la vida.

@manuellabastida

TheDary
Novato
Mensajes: 13
Registrado: 03 Nov 2012, 07:54

Re: Tiempos de inicio con systemd

Mensaje por TheDary » 04 Dic 2012, 16:31

El mio:

Código: Seleccionar todo

Startup finished in 2643ms (kernel) + 36184ms (userspace) = 38827ms
 15408ms [email protected]
  3578ms polkit.service
  1838ms dnsmasq.service
  1665ms systemd-logind.service
  1106ms systemd-vconsole-setup.service
   589ms systemd-remount-fs.service
   460ms systemd-binfmt.service
   405ms sys-kernel-debug.mount
   397ms systemd-tmpfiles-setup.service
   387ms dev-hugepages.mount
   376ms dev-mqueue.mount
   295ms systemd-udev-trigger.service
   292ms systemd-udevd.service
   250ms proc-sys-fs-binfmt_misc.mount
   152ms home.mount
    97ms udisks2.service
    73ms systemd-sysctl.service
    64ms boot.mount
    40ms rtkit-daemon.service
    29ms systemd-user-sessions.service
    24ms tmp.mount
    24ms dev-sda2.swap

blackleg
Archer
Archer
Mensajes: 33
Registrado: 03 Ene 2013, 13:30

Re: Tiempos de inicio con systemd

Mensaje por blackleg » 03 Ene 2013, 13:40

Que tal este?

Código: Seleccionar todo

Startup finished in 1007ms (kernel) + 1275ms (userspace) = 2283ms
   490ms NetworkManager.service
   460ms bluetooth.service
   350ms systemd-logind.service
   199ms systemd-user-sessions.service
   139ms systemd-udev-trigger.service
   133ms tmp.mount
   123ms systemd-binfmt.service
   107ms systemd-remount-fs.service
   101ms systemd-vconsole-setup.service
    95ms polkit.service
    93ms systemd-udevd.service
    78ms dev-mqueue.mount
    60ms dev-hugepages.mount
    43ms sys-kernel-debug.mount
    39ms systemd-sysctl.service
    33ms gdm.service
    25ms udisks2.service
    17ms proc-sys-fs-binfmt_misc.mount
    15ms accounts-daemon.service
    13ms boot-efi.mount
    13ms systemd-tmpfiles-setup.service
    11ms home.mount
     9ms colord.service
     8ms upower.service
     7ms rtkit-daemon.service
     6ms wpa_supplicant.service
     3ms home-hector-.cache-chromium.mount
     2ms systemd-hostnamed.service
     1ms sys-fs-fuse-connections.mount

Avatar de Usuario
davidlghellin
Archer Avanzado
Archer Avanzado
Mensajes: 112
Registrado: 09 Mar 2012, 10:53
Ubicación: Albacete, España

Re: Tiempos de inicio con systemd

Mensaje por davidlghellin » 03 Ene 2013, 16:42

Mi PC

Código: Seleccionar todo

Startup finished in 4798ms (kernel) + 10202ms (userspace) = 15000ms
  4365ms wicd.service
  3515ms net-auto-wireless.service
  1287ms systemd-logind.service
   686ms systemd-vconsole-setup.service
   586ms systemd-udev-trigger.service
   584ms mnt-windows.mount
   579ms systemd-binfmt.service
   528ms udisks2.service
   466ms polkit.service
   353ms dev-sda8.swap
   353ms systemd-tmpfiles-setup.service
   261ms tmp.mount
   260ms systemd-remount-fs.service
   256ms mnt-Multimedia.mount
   244ms home.mount
   223ms dev-mqueue.mount
   216ms sys-kernel-debug.mount
   175ms boot.mount
   174ms systemd-udevd.service
   173ms dev-hugepages.mount
    74ms proc-sys-fs-binfmt_misc.mount
    50ms udisks.service
    43ms upower.service
    41ms systemd-sysctl.service
    33ms systemd-user-sessions.service
    14ms sys-fs-fuse-connections.mount
Mi portátil

Código: Seleccionar todo

Startup finished in 5853ms (kernel) + 13440ms (userspace) = 19293ms
  6118ms wicd.service
  4011ms net-auto-wireless.service
  1204ms systemd-vconsole-setup.service
  1002ms systemd-remount-fs.service
   971ms tmp.mount
   942ms dev-hugepages.mount
   923ms dev-mqueue.mount
   905ms sys-kernel-debug.mount
   903ms systemd-logind.service
   895ms systemd-udev-trigger.service
   428ms polkit.service
   416ms systemd-tmpfiles-setup.service
   309ms home.mount
   302ms udisks2.service
   131ms systemd-user-sessions.service
   109ms systemd-udevd.service
    99ms systemd-sysctl.service
    92ms udisks.service
    40ms upower.service
    40ms boot.mount
Teniendo casi lo mismo instalado, creo que se podría mejorar los tiempos; pero eso más adelante
Si existiera la certeza no estaría la estadística
Usuario Linux #553802

Responder