Pantalla negra al Cerrar Sesión Gnome - Xfce

Todo lo relacionado con los entornos de escritorio, todas las aplicaciones, tanto KDE, Gnome y otros. Si tenes un problema con un programa, muy probablemente este sea el foro indicado.
Responder
cmchecha
Novato
Mensajes: 4
Registrado: 22 Mar 2016, 02:17

Pantalla negra al Cerrar Sesión Gnome - Xfce

Mensaje por cmchecha » 22 Mar 2016, 02:28

Buen día amigos. Les cuento que soy nuevo en ésta distro de Linux. El caso viene que lo acabo de instalar hace poco y la instalación más que buena, seguí los pasos que están en la wiki. Todo excelente. Instalé el entorno gráfico Gnome 3 y buenísimo, todo a la perfección, pero ayer instalé el Xfce4 para presumir un poco xD y también funciona. El caso es que cuando cierro sesión en cualquiera de estos entornos se me congela la pantalla, se queda una pantalla negra sin nada, pienso que es algún bug o algo, cosa que no pasaba cuando solo tenía Gnome 3. No sé si se pueda solucionar ésto. De antemano, por la ayuda, Muchas Gracias.
L :!: AD :shock:

tenshal
Archer
Archer
Mensajes: 50
Registrado: 09 May 2011, 14:02
Ubicación: Orizaba, México

Re: Pantalla negra al Cerrar Sesión Gnome - Xfce

Mensaje por tenshal » 29 Mar 2016, 18:50

A mi me pasa lo mismo (tengo instalado XFCE4 y anteriormente tuve openbox). Cuando tenría instalado openbox igual no podía cerrar sesión, reiniciar y mucho menos apagar mi pc desde el entorno gráfico, sólo podía hacer todo eso cuando estaba en una tty. Buscando y buscando encontré información de no sé donde y logré solucionarlo y ahora que hice una nueva instalción pero con XFCE4 tengo el mismo problema (nunca se me ocurrió guardar dicha solución)
Recuerdo que después de iniciar sesión desde la tty (nunca me a gustado usar alguna pantalla de login) introducia:

Código: Seleccionar todo

sudo sysctl -p
y sólo así lograba apagar mi pc

En la nueva instalación que hice el domingo (27/03/2016) he intentado resolver el problema creando el archivo en /etc/sysctl.conf y poniendo lo siguiente:

Código: Seleccionar todo

	kernel .shmmax = 128000000
	kernel.sysrq = 1
que es tal y como lo tengo en la otra pc pero no he logrado resolverlo ni he obtenido respuesta.
Este es el tema que abrí al respecto: http://foros.archlinux-es.org/viewtopic ... 277#p46277

tenshal
Archer
Archer
Mensajes: 50
Registrado: 09 May 2011, 14:02
Ubicación: Orizaba, México

Re: Pantalla negra al Cerrar Sesión Gnome - Xfce

Mensaje por tenshal » 30 Mar 2016, 14:44

Buscando información sobre lo que me está pasando y que al parecer tambien a ti, encontré lo siguiente:
Network Manager espero y te sirva de algo.(yo aún no he hecho eso por falta de tiempo)
Saludos

cmchecha
Novato
Mensajes: 4
Registrado: 22 Mar 2016, 02:17

Re: Pantalla negra al Cerrar Sesión Gnome - Xfce

Mensaje por cmchecha » 01 Abr 2016, 02:07

Gracias tenshall por la info. Pues fijate que no lo he podido solucionar pero igualmente gracias por tu ayuda. y es que he estado muy ocupado con tareas y trabajo que no me ha dado tiempo para resolver el problema. En un tiempo lo estaré probando Gracias por tu ayuda tenshal.
L :!: AD :shock:

tenshal
Archer
Archer
Mensajes: 50
Registrado: 09 May 2011, 14:02
Ubicación: Orizaba, México

Re: Pantalla negra al Cerrar Sesión Gnome - Xfce

Mensaje por tenshal » 04 Abr 2016, 15:35

cmchecha escribió:Gracias tenshall por la info. Pues fijate que no lo he podido solucionar pero igualmente gracias por tu ayuda. y es que he estado muy ocupado con tareas y trabajo que no me ha dado tiempo para resolver el problema. En un tiempo lo estaré probando Gracias por tu ayuda tenshal.
Sabes otro modo que encontre para poder apagar o reiniciar la pc es por medio de la combinacion de teclas sysrq REISUB (para reiniciar) y REISUO (PARA APAGAR) algo ortodoxa la solución pero funciona.

Para activar el soporte basta hacer:

Código: Seleccionar todo

sudo nano /etc/sysctl.conf
y activarlo ya que por defecto estara en 0.Dejarlo en 1:

Código: Seleccionar todo

#Disable the magic-sysrq key
kernel.sysrq = 1
Más informacion en : Combinación de teclas de emergencia para Linux

Responder