WIFI: sin conexion [Solucionado]

Todo lo relacionado con los entornos de escritorio, todas las aplicaciones, tanto KDE, Gnome y otros. Si tenes un problema con un programa, muy probablemente este sea el foro indicado.
Responder
Avatar de Usuario
atb
Archer
Archer
Mensajes: 30
Registrado: 22 Nov 2016, 10:52

WIFI: sin conexion [Solucionado]

Mensaje por atb » 27 Nov 2016, 14:38

!Saludos atentos!
Nuevo en Linux y en Arch.
Recien instalado arch ("Guía ArchWiki") en un portatil Dell Inspiron 6400, pero sigo sin conexión. Debo decir que antes instalé Xbuntu y el wifi funcionó bien. He conseguido lo siguiente,

Durante la instalación:

Código: Seleccionar todo

systemctl start NetworkManager.service
systemctl enable NetworkManager.service
Despues de instalar Xfce:

Código: Seleccionar todo

wifi-menu
He seleccionado con éxito mi red wifi y entrado el password, pero sigo sin conexión, con el siguiente error:
"exited with error" "See "systemctl status" and "journalctl -xe"
"service failed because the control process exited with error code.

Por favor, ¿en que dirección debo continuar?

Gracias de antemano: Alberto
Última edición por atb el 02 Dic 2016, 07:18, editado 2 veces en total.
"Las cosas que nosotros compartimos en nuestro mundo son mucho más valiosas que las que nos dividen."
- Donald Williams, EUA

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1774
Registrado: 18 Nov 2010, 23:33
Ubicación: Behind your computer

Re: WIFI: sin conexion (nueva consulta)

Mensaje por Spooky » 27 Nov 2016, 22:57

NetworkManager junto a XFCE?
Cómo sea, ya tienes instalado el gestor de redes wireless, ahora, cómo pretendes conectarte desde el?

Requieres un applet, una interfaz gráfica para seleccionar la red.
Por qué estás con wifi-menu, pero para ese necesitas configurar netctl:
https://wiki.archlinux.org/index.php/netctl
Más info:
https://wiki.archlinux.org/index.php/Wi ... atic_setup

También revisa que arroja systemctl:

Código: Seleccionar todo

 systemctl status NetworkManager

Avatar de Usuario
atb
Archer
Archer
Mensajes: 30
Registrado: 22 Nov 2016, 10:52

Re: WIFI: sin conexion (nueva consulta)

Mensaje por atb » 28 Nov 2016, 05:33

Hola de nuevo. Por favor, ¿podeis seguir ayudandome con mi conexion wifi?
Despues de leer las referencias que me hizo Spooky, esto es lo que he hecho:

Código: Seleccionar todo

$ netctl start mi_wifi
Salida:

Código: Seleccionar todo

Job for [email protected]_wifi.service failed because the control process exited with error code.
See "systemctl status [email protected]_wifi.service" and "journalctl -xe" for details.
"Las cosas que nosotros compartimos en nuestro mundo son mucho más valiosas que las que nos dividen."
- Donald Williams, EUA

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1774
Registrado: 18 Nov 2010, 23:33
Ubicación: Behind your computer

Re: WIFI: sin conexion (nueva consulta)

Mensaje por Spooky » 28 Nov 2016, 20:10

No no..
Actualmente ya tienes habilitado un gestor de redes, que en este caso es NetworkManager.
Entonces para usar netctl primero debes parar el servicio networkmanager y luego deshabilitarlo para que no inicie de manera automática:

Código: Seleccionar todo

systemctl stop NetworkManager
systemctl disable NetworkManager
Luego te creas un perfil dentro de /etc/netctl y lo activas con:

Código: Seleccionar todo

netctl enable perfil
El perfil mi_wifi que contiene?
Con wifi-menu tambien puedes generar un perfil de manera automatica:

Código: Seleccionar todo

wifi-menu -o
Luego lo activas como lo indique un poco mas arriba.

De igual manera debes escoger que quieres usar para gestionar tus redes, ya sea con algo automático como networkmanager,wicd, o algo que requiere mas configuración como netctl.

Avatar de Usuario
atb
Archer
Archer
Mensajes: 30
Registrado: 22 Nov 2016, 10:52

Re: WIFI: sin conexion (nueva consulta)

Mensaje por atb » 28 Nov 2016, 20:50

Este es el contenido del perfil mi_wifi:

Código: Seleccionar todo

Description='A simple WPA encrypted wireless connection'
Interface=wlan0
Connection=wireless
Security=wpa
IP=dhcp
ESSID=mi_network
# Prepend hexadecimal keys with \"
# If your key starts with ", write it as '""<key>"'
# See also: the section on special quoting rules in netctl.profile(5)
Key=mi_password
# Uncomment this if your ssid is hidden
#Hidden=yes
# Set a priority for automatic profile selection
#Priority=10
"Las cosas que nosotros compartimos en nuestro mundo son mucho más valiosas que las que nos dividen."
- Donald Williams, EUA

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1774
Registrado: 18 Nov 2010, 23:33
Ubicación: Behind your computer

Re: WIFI: sin conexion (nueva consulta)

Mensaje por Spooky » 28 Nov 2016, 21:35

Copiaste uno de los archivos de ejemplo, pero seguro que los datos corresponden a los de tu red?
Por ejemplo, estoy casi seguro de que tu interfaz wireless no se llama wlan0.
No te compliques y genera un perfil de manera automática:

Código: Seleccionar todo

wifi-menu -o
Selecciona tu red, coloca tu password, conectate a la red y listo, netctl creara el perfil.
Luego ya solo queda activarlo:

Código: Seleccionar todo

netctl enable el_perfil

Avatar de Usuario
atb
Archer
Archer
Mensajes: 30
Registrado: 22 Nov 2016, 10:52

Re: WIFI: sin conexion (nueva consulta)

Mensaje por atb » 29 Nov 2016, 05:07

Ok, haré lo que me indicas y vuelvo con la respuesta.
Gracias por tu tiempo y paciencia.
"Las cosas que nosotros compartimos en nuestro mundo son mucho más valiosas que las que nos dividen."
- Donald Williams, EUA

Avatar de Usuario
atb
Archer
Archer
Mensajes: 30
Registrado: 22 Nov 2016, 10:52

Re: WIFI: sin conexion (nueva consulta)

Mensaje por atb » 29 Nov 2016, 17:51

Hola de nuevo Spooky,
¡En estos momentos ya disfruto de conexión wifi! Resumo la solución que me diste para que sirva de ayuda a quien tenga el mismo problema.

Había un conflicto con NetworkManager con el cual ya había habilitado un gestor de red.
1.- Para usar netctl paré el servicio networkmanager.

Código: Seleccionar todo

systemctl stop NetworkManager
systemctl disable NetworkManager
2.- Generé un perfil automaticamente.

Código: Seleccionar todo

wifi-menu -o
3.- Activé el perfil

Código: Seleccionar todo

netctl enable el_perfil
Muchas gracias por tu ayuda; edito el encabezamiento como resuelto, y hasta pronto.
"Las cosas que nosotros compartimos en nuestro mundo son mucho más valiosas que las que nos dividen."
- Donald Williams, EUA

Avatar de Usuario
sud_crow
Administrador
Administrador
Mensajes: 951
Registrado: 16 Abr 2005, 00:38
Ubicación: Buenos Aires - Argentina
Contactar:

Re: WIFI: sin conexion [Soluciondo]

Mensaje por sud_crow » 30 Nov 2016, 00:39

@atb para que tengas en cuenta, así como cualquier otro que vea el hilo:

Si instalas NetworkManager, tenes que instalar el gestor GUI además del demonio para poder administrar las conexiones de forma amigable. Los paquetes recomendados para XFCE serían:

Código: Seleccionar todo

pacman -Sy networkmanager
pacman -Sy network-manager-applet
pacman -Sy xfce4-notifyd
Fuente:
https://wiki.archlinux.org/index.php/Ne ... B1ol)#XFCE

La otra opción es utiliar netctl como estás haciendo y te indico Spooky, pero tené en cuenta que la gestión de perfiles es menos amigable y para las laptops si la utilizas en distintos lugares y conexiones puede ser más complicado de resolver alguna conexión (particularmente en lugares públicos).

Saludos!
¿Revisaste la wiki? | ¿Usaste la función buscar del foro? | ¿Leíste las normas del foro?
Blog : | Correo+Jabber: leonardo @ archlinux-es.org

Responder