Problema Instalación Conky-lua

Todo lo relacionado con los entornos de escritorio, todas las aplicaciones, tanto KDE, Gnome y otros. Si tenes un problema con un programa, muy probablemente este sea el foro indicado.
Responder
MrDoS
Novato
Mensajes: 2
Registrado: 12 Mar 2017, 02:45

Problema Instalación Conky-lua

Mensaje por MrDoS » 21 Jul 2017, 01:56

Hola que tal Chicos,

Esta es la primera vez que posteo en el foro de archlinux ^^, asi que os espero tengais paciencia con este tio jeje, bueno el problema que he tenido es basicamente que estoy en arch con fluxbox, y estoy tratando de instalar conky-lua para poder visualizar los anillos del tema rings que esta en conky con soporte lua, asi que borre el conky que habia instalado porque lei por ahi que el conky que esta en los repositorios de arch es un conky a secas (sin LUA), asi que lo desinstale e instale conky-lua de AUR, el tema es que al ejecutar
yaourt -S conky-lua, me saltan errores de compilacion de makepkg, este es el log de errores que me da...

Código: Seleccionar todo

yaourt -S conky-lua

==> Descargando PKGBUILD para conky-lua desde el AUR...
x .SRCINFO
x PKGBUILD
x include_functional.patch
Linuxplorer commented on 2017-06-21 22:50			 
oberon2007, this seems to be missing a dependency on git.

cheers

Xyne commented on 2017-06-21 23:15			 
"git" should be added as a (build or runtime) dependency *only* if it is a direct dependency of conky-lua. From the discussion on the forum[1], which is still not finished, it seems that one of the dependencies of this package is missing "git" in its own PKGBUILD. That is the resonsibility of the that package's maintainer.
[1] https://bbs.archlinux.org/viewtopic.php?id=227498

graybeard commented on 2017-07-18 20:26			 
I am experiencing the exact same issue as argamanaz did back on 2016-04-16.
A solution was never posted.
Does anyone know why the file is not downloading? When done manually it download without an issue.

oberon2007 commented on 2017-07-18 20:39			 
I cannot reproduce this, @graybeard. Maybe it's just a problem with internet or server speed?

graybeard commented on 2017-07-19 12:11			 
I found the issue.  Line 61 in doc/CMakeFiles/docs.dir/build.make is the problem.  xsltproc was not downloading the file.  A look at the Docbook Wiki shows this as a none error.  As suggested I reinstalled docbook-xsl and docbook-xlt.  The package installed without a hitch.

conky-lua 1.10.6-1  (2017-06-01 07:50)
(Paquete sin soporte: ¡podría ser peligroso!)
==> ¿Quiere editar PKGBUILD? [S/n] («A» para anular)
==> ------------------------------------------------
==> 

Por favor, añada $VISUAL a las variables de entorno
por ejemplo:
export VISUAL="vim" (en ~/.bashrc)
(remplace vim por su editor preferido)

==> Editar PKGBUILD con:  

/usr/lib/yaourt/util.sh: línea 227: PKGBUILD: no se encontró la orden
==> dependencias de conky-lua:
 - alsa-lib (ya instalado)
 - cairo (ya instalado)
 - curl (ya instalado)
 - glib2 (ya instalado)
 - imlib2 (ya instalado)
 - libxdamage (ya instalado)
 - libxft (ya instalado)
 - libxml2 (ya instalado) [makedepend]
 - lua51 (ya instalado)
 - tolua++ (ya instalado)
 - wireless_tools (ya instalado)
 - cmake (ya instalado) [makedepend]
 - docbook2x (ya instalado) [makedepend]
 - docbook-xml (ya instalado) [makedepend]
 - docbook-xsl (ya instalado) [makedepend]
 - librsvg (ya instalado) [makedepend]
 - libxinerama (ya instalado) [makedepend]
 - libxml2 (ya instalado) [makedepend]
 - man-db (ya instalado) [makedepend]
 - perl-xml-libxml (ya instalado) [makedepend]


==> ¿Continuar compilando conky-lua? [S/n]
==> --------------------------------------
==> S

==> Compilando e instalando el paquete
==> Creando el paquete: conky-lua 1.10.6-1 (jue jul 20 20:49:34 -04 2017)
==> Comprobando dependencias mientras se ejecuta...
==> Comprobando dependencias mientras se compila...
==> Recibiendo las fuentes...
  -> Descargando v1.10.6.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   126    0   126    0     0    133      0 --:--:-- --:--:-- --:--:--   133
100  357k    0  357k    0     0   144k      0 --:--:--  0:00:02 --:--:--  487k
  -> include_functional.patch ha sido encontrado 
==> Validando los archivos source con sha1sums...
    v1.10.6.tar.gz ... Aprobado
    include_functional.patch ... Aprobado
==> Extrayendo las fuentes...
  -> Extrayendo v1.10.6.tar.gz con bsdtar
==> Iniciando prepare()...
patching file src/luamm.hh
==> Iniciando build()...
-- The C compiler identification is GNU 7.1.1
-- The CXX compiler identification is GNU 7.1.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
CMake Error at cmake/Conky.cmake:97 (message):
  Unable to find program 'git'
Call Stack (most recent call first):
  CMakeLists.txt:31 (include)


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-mrdos/aur-conky-lua/src/conky-1.10.6/CMakeFiles/CMakeOutput.log".
See also "/tmp/yaourt-tmp-mrdos/aur-conky-lua/src/conky-1.10.6/CMakeFiles/CMakeError.log".
==> ERROR: Se produjo un fallo en build().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar conky-lua.
==> ¿Reiniciar la compilación de conky-lua? [s/N]
==> ---------------------------------------------
==> 
Sinceramente, no tengo mucha experiencia en arch, se bien como gestionar los paquetes y creo que estoy bastante bien acostumbrado al sistema para llevar tan poco, por la cantidad de estudio y empeño le he puesto, pero ya le meti tanta mano la otra vez que me rendi.....ojala pueda alguien echarme una mano se lo agradeceria :)

Avatar de Usuario
Skatox
Equipo Hispano
Equipo Hispano
Mensajes: 510
Registrado: 21 Ago 2006, 23:19
Ubicación: Venezuela
Contactar:

Re: Problema Instalación Conky-lua

Mensaje por Skatox » 26 Jul 2017, 11:05

Los scripts de AUR son hechos por usuarios, por eso no son perfectos, en este caso, te hace falta instalar "git" para poder continuar, tambien te recomiendo instalar "base-devel" que te instala muchas herramientas de compilación.
WWW.SKATOX.COM: Blog sobre desarrollo web, Linux, Hacking, Videojuegos y más :P

Responder