Problema conexión wifi

Todo lo relacionado con hacer funcionar a Arch como servidor de lo que sea (pagina web, ftp, archivos, firewall & router, etc...).
Responder
palinux
Novato
Mensajes: 2
Registrado: 26 Jul 2013, 18:48

Problema conexión wifi

Mensaje por palinux » 26 Jul 2013, 19:32

Ante todo, saludos a todos quienes participan del foro.

Hace años usé Arch por unos 2-3 años aproximadamente, pero tras cambiar mi portátil me costó bastante instalarlo por el tema de las tarjetas gráficas híbridas. Finalmente lo logré y regresé a mi querida distribución Arch.

Dicho esto, quiero comentarles que he tenido un gran problema con la conexión wifi. He leído los diferentes temas tratados al respecto por lo que aportaré con la mayor información posible respecto a mi situacion. Lo que pasa es que tengo conexión a internet via cable ethernet sin problemas, pero cuando quiero conectarme a wifi sólo lo logro por un par de segundos (10 aproximadamente) y luego me quedo sin internet, por lo que creo hay un problema con la asociacion del "dhcp" y la tarjeta wifi.
Por cierto, mi laptop trae la tarjeta

Código: Seleccionar todo

16:02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
y uso el controlador "iwlwifi"


Uso gnome y NetworkManager. Tengo todo actualizado a día de hoy. Y también trabajo con systemd.

Aqui voy:

Código: Seleccionar todo

[[email protected] ~]$ ifconfig
enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.50.22  netmask 255.255.255.0  broadcast 192.168.50.255
        inet6 fe80::f2bf:97ff:fe14:d740  prefixlen 64  scopeid 0x20<link>
        ether f0:bf:97:14:d7:40  txqueuelen 1000  (Ethernet)
        RX packets 323  bytes 209950 (205.0 KiB)
        RX errors 0  dropped 2  overruns 0  frame 0
        TX packets 334  bytes 57800 (56.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 1  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 8c:a9:82:40:02:ec  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
De ahí obtengo que mi tarjeta wifi es "wlp2s0", por lo que hago lo lógico:

Código: Seleccionar todo

[[email protected] palinux]# systemctl start [email protected]
Job for [email protected] failed. See 'systemctl status [email protected]' and 'journalctl -xn' for details.
y luego:

Código: Seleccionar todo

[[email protected] palinux]# systemctl status [email protected]
[email protected] - dhcpcd on wlp2s0
   Loaded: loaded (/usr/lib/systemd/system/[email protected]; enabled)
   Active: failed (Result: exit-code) since vie 2013-07-26 18:10:31 CLT; 5s ago
  Process: 1069 ExecStart=/usr/sbin/dhcpcd -q -w %I (code=exited, status=1/FAILURE)

jul 26 18:10:31 archlinux systemd[1]: [email protected]: control process exited, code=exited status=1
jul 26 18:10:31 archlinux systemd[1]: Failed to start dhcpcd on wlp2s0.
jul 26 18:10:31 archlinux systemd[1]: Unit [email protected] entered failed state.
probé dandole a "enable" en vez de start y al revisar el "status", es la misma respuesta tanto con

Código: Seleccionar todo

systemctl enable [email protected]
como con

Código: Seleccionar todo

systemctl enable [email protected]
Un detalle que puede ser importante para encontrar el fallo, es que si escribo "systemctl restart NetworkManager" pierdo la conexión a internet por cable, la cual recupero al reiniciar.
En cambio, al desconectar el cable y volver a conectarlo (sin reiniciar NetworkManager) mantengo internet.

En otra de las pruebas que he realizado, probé desactivando el dhcpcd (systemctl disable dhcpcd) y al reiniciar, sigo en la misma situación.. con internet por cable, pero no por wifi


A alguien se le ocurre una posible solución?
De antemano muchas gracias!

palinux
Novato
Mensajes: 2
Registrado: 26 Jul 2013, 18:48

Re: Problema conexión wifi

Mensaje por palinux » 26 Jul 2013, 19:37

Al reiniciar, pruebo esto:

Código: Seleccionar todo

[[email protected] palinux]# systemctl status [email protected]
[email protected] - dhcpcd on wlp2s0
   Loaded: loaded (/usr/lib/systemd/system/[email protected]; enabled)
   Active: active (running) since vie 2013-07-26 18:27:39 CLT; 7min ago
  Process: 217 ExecStart=/usr/sbin/dhcpcd -q -w %I (code=exited, status=0/SUCCESS)
 Main PID: 526 (dhcpcd)
   CGroup: name=systemd:/system/[email protected]/[email protected]
           └─526 /usr/sbin/dhcpcd -q -w wlp2s0

jul 26 18:34:50 archlinux dhcpcd[526]: wlp2s0: broadcasting for a lease
jul 26 18:34:50 archlinux dhcpcd[526]: wlp2s0: offered 192.168.50.19 from 192.168.50.1
jul 26 18:34:52 archlinux dhcpcd[526]: wlp2s0: acknowledged 192.168.50.19 from 192.168.50.1
jul 26 18:34:52 archlinux dhcpcd[526]: wlp2s0: checking for 192.168.50.19
jul 26 18:34:53 archlinux dhcpcd[526]: wlp2s0: sending IPv6 Router Solicitation
jul 26 18:34:57 archlinux dhcpcd[526]: wlp2s0: sending IPv6 Router Solicitation
jul 26 18:34:57 archlinux dhcpcd[526]: wlp2s0: no IPv6 Routers available
jul 26 18:34:58 archlinux dhcpcd[526]: wlp2s0: leased 192.168.50.19 for 3600 seconds
jul 26 18:35:05 archlinux dhcpcd[526]: wlp2s0: removing IP address 192.168.50.19/24
jul 26 18:35:05 archlinux dhcpcd[526]: wlp2s0: carrier lost
y al cabo de unos segundos, lo repito:

Código: Seleccionar todo

[[email protected] palinux]# systemctl status [email protected]
[email protected] - dhcpcd on wlp2s0
   Loaded: loaded (/usr/lib/systemd/system/[email protected]; enabled)
   Active: active (running) since vie 2013-07-26 18:27:39 CLT; 9min ago
  Process: 217 ExecStart=/usr/sbin/dhcpcd -q -w %I (code=exited, status=0/SUCCESS)
 Main PID: 526 (dhcpcd)
   CGroup: name=systemd:/system/[email protected]/[email protected]
           └─526 /usr/sbin/dhcpcd -q -w wlp2s0

jul 26 18:35:09 archlinux dhcpcd[526]: wlp2s0: sendmsg: Cannot assign requested address
jul 26 18:35:09 archlinux dhcpcd[526]: wlp2s0: rebinding lease of 192.168.50.19
jul 26 18:35:13 archlinux dhcpcd[526]: wlp2s0: sending IPv6 Router Solicitation
jul 26 18:35:14 archlinux dhcpcd[526]: wlp2s0: acknowledged 192.168.50.19 from 192.168.50.1
jul 26 18:35:14 archlinux dhcpcd[526]: wlp2s0: checking for 192.168.50.19
jul 26 18:35:17 archlinux dhcpcd[526]: wlp2s0: sending IPv6 Router Solicitation
jul 26 18:35:19 archlinux dhcpcd[526]: wlp2s0: leased 192.168.50.19 for 3600 seconds
jul 26 18:35:21 archlinux dhcpcd[526]: wlp2s0: sending IPv6 Router Solicitation
jul 26 18:35:21 archlinux dhcpcd[526]: wlp2s0: no IPv6 Routers available
jul 26 18:35:29 archlinux dhcpcd[526]: wlp2s0: carrier lost
y aún así no logro conexión por wifi.

Avatar de Usuario
Jristz
Archer Extremo
Archer Extremo
Mensajes: 745
Registrado: 14 Mar 2011, 20:20

Re: Problema conexión wifi

Mensaje por Jristz » 30 Jul 2013, 10:16

er.... Como se va aconectar si no save a que red conectarse??
yo por wi-fi uso wifi-menu parte de netctl, y luego pruebo el dhcpcd, luego de conectarme
System: Host: Netbook Kernel: 4.4.39-1-lts x86_64 (64 bit) Desktop: Xfce 4.12.3 Distro: Arch Linux
Machine: Device: laptop System: TOSHIBA product: Satellite C845D v: PSCB6P-002LM1
Mobo: AMD model: Renmore UEFI: Insyde v: 6.10 date: 09/14/2012
Battery[/b] BAT1: charge: 5.3 Wh 17.5% condition: 30.4/44.0 Wh (69%)
CPU: Dual core AMD E-300 APU with Radeon HD Graphics (-MCP-) speed: 1300 MHz (max)
Graphics: Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6310]

Avatar de Usuario
FWolf
Archer
Archer
Mensajes: 25
Registrado: 01 Jun 2013, 16:02
Ubicación: España

Re: Problema conexión wifi

Mensaje por FWolf » 01 Ago 2013, 09:11


evilside
Archer
Archer
Mensajes: 52
Registrado: 09 Nov 2010, 02:15

Re: Problema conexión wifi

Mensaje por evilside » 26 Ago 2013, 22:41

Supongo que antes de hacer systemctl start [email protected] te conectaste a la red inalámbrica con wpa_supplicant, ¿o no? Si no, no va conseguir DHCP nunca.

Por otro lado. esta manera de conectar que describes, manipulando el demonio dhcpcd, es del tipo manual. Si usas Network Manager la conexión es automática, el llama a wpa_supplicant para conectar al Wifi y luego a dhcpcd para obtener la configuración IP.

Bueno, quizás ya sabes todo eso y sólo omitiste esa parte, pero como no lo mencionas, mejor salir de la duda.

Responder