configuración wifi en Raspberry Pi

Todo lo relacionado con hacer funcionar a Arch como servidor de lo que sea (pagina web, ftp, archivos, firewall & router, etc...).
Responder
Theasker
Novato
Mensajes: 5
Registrado: 07 Ago 2013, 15:45

configuración wifi en Raspberry Pi

Mensaje por Theasker » 30 Ago 2013, 15:14

Hola:

Estoy instalando configurando la red wifi en mi Raspberry siguiendo la wiki de arch. He seguido unos mínimos pasos para configurarla:

0. pacman -S wireless_tools
1. wifi-menu
2. luego he configurado el archivo para que tenga una ip estática
3. netctl enable <archivo de configuración>
4. Configuro el archivo /etc/resolv.conf
5. reboot

Luego al arrancar, y al hacer un ifconfig la interfaz wlan0 está configurada correctamente y puedo conectarme por ssh perfectamente a la raspberry configurada por wifi, pero no puedo salir fuera de la red interna, es decir, no puedo obtengo respuesta al hacer un ping a http://www.google.com.

Gracias anticipadas por la ayuda

Avatar de Usuario
josejuan
Archer Extremo
Archer Extremo
Mensajes: 320
Registrado: 02 Dic 2010, 08:12
Contactar:

Re: configuración wifi en Raspberry Pi

Mensaje por josejuan » 31 Ago 2013, 05:01

Entonces lo más difícil ya lo has hecho, te falta configurar los dns.

Como has configurado un IP estática (no DHCP) entonces debes configurar también los DNS.

¿Has metido en resolv.conf los servidores DNS?, https://wiki.archlinux.org/index.php/Resolv.conf

Theasker
Novato
Mensajes: 5
Registrado: 07 Ago 2013, 15:45

Re: configuración wifi en Raspberry Pi

Mensaje por Theasker » 31 Ago 2013, 18:40

Código: Seleccionar todo

# cat /etc/netctl/wlan0-TheaskerWiFi 
Description='Automatically generated profile by wifi-menu'
Interface=wlan0
Connection=wireless
Security=wpa
ESSID=TheaskerWiFi
IP=static
Key='12345678901234567890123456'
Address='192.168.0.70/24'
Gateway='192.168.0.1'
DNS=('208.67.222.222','208.67.220.220')
Y según la página de configuración de /etc/resolv.conf que me has comentado tengo configurado el archivo igual que en el manual ya que yo uso los dns de opendns:

Código: Seleccionar todo

# cat /etc/resolv.conf
# OpenDNS servers
nameserver 208.67.222.222
nameserver 208.67.220.220

Código: Seleccionar todo

# cat /etc/resolv.conf.head 
# OpenDNS servers
nameserver 208.67.222.222
nameserver 208.67.220.220
Ayer me conecté al grupo del irc de archlinux-es para ver si me podían ayudar un poco, ya que yo entiendo que había configurado bien la wifi y ya no sabía que hacer y me comentaron que podía ser un bug del archlinux de la arquitectura de arm. El problema que puede ser es que yo uso una versión de arch a la cual he sustituido todos los enlaces simbólicos de bin->/usr/bin, bin->/usr/bin y sbin->/usr/bin por una simple copia del directorio /usr/bin. Ya que estoy utilizando un gestor de arranque especifico para Raspberry Pi, que permite poder arrancar desde varios sistemas operativos, y que funciona con imagenes squashfs, pero que no pueden contener enlaces simbólicos (por eso lo de eliminar los enlaces y sustituirlos por una copia). La generación de la imagen de arch en squashfs, la hice yo siguiendo los numerosos manuales sencillos que hay por ahí y con la ayuda de los comandos kpartx y mksquashfs.

Pienso que puede que ese sea ese el problema en conjunción con que el arch que uso no es un arch oficial.

O otra posibilidad mucho más posible (valga la dedundancia) es que haya hecho yo algo mal, aunque después de llevar una semana a una media de 4 ó 5 horas con el tema, he simplificado todo a los pasos que he puesto en el primer post.

De todas formas si falta algo o me he saltado un paso, estoy abierto a todas las críticas. Llevo muy poco tiempo en esto de arch, poco más de una semana. Yo vengo de Gentoo y arch es lo que más se le parece y me gusta.

Un saludo a todos y gracias anticipadas de nuevo

Theasker
Novato
Mensajes: 5
Registrado: 07 Ago 2013, 15:45

Re: configuración wifi en Raspberry Pi

Mensaje por Theasker » 31 Ago 2013, 18:54

Parece que no sirvió con netctl restart wlan0-TheaskerWiFi, pero al hacer un reboot funcionó perfectamente con la configuración de resolv.conf.

Por lo que se ve el problema era que sobreescribía ese archivo con la línea <b>nameserver 208.67.222.222, 208.67.220.220</b>, la cual no tiene una sintaxis correcta, por lo que la configuración de ips estática era correcta pero no la resolución de nombres por lo que no podía salir fuera. Y al añadir la configuración del archivo /etc/dhcpcd.conf: nohook resolv.conf, se supone que "bloquea" la modificación del archivo resolv.conf, cosa que no entiendo muy bien ya que yo el servidor dhcpd lo tenía descontectado cuando hice systemctl disable dhcpd.

en cualquiera de los casos, muchas gracias josejuan. Ya estoy buscando un sitio en mis discos para instalar arch al lado de mi gentoo, por ahora ya llevo 7 años con gentoo, a ver si me dura como poco los mismos.

Nos vemos por aqui y gracias de nuevo

Responder