Problema con el Servicio No-ip

Todo lo relacionado con hacer funcionar a Arch como servidor de lo que sea (pagina web, ftp, archivos, firewall & router, etc...).
Responder
donpiluso
Novato
Mensajes: 9
Registrado: 20 Abr 2014, 04:30

Problema con el Servicio No-ip

Mensaje por donpiluso » 31 Oct 2015, 16:20

Hola a todos!.

De nuevo por acá para molestarlos con una consulta a ver si logro solucionarla.

Instalé Arch en una notebook vieja, para usarla como un servidor local simple. Instalé No-ip para permitir acceder al servidor web desde afuera.

Pero estoy teniendo problema para que actualice correctamente al iniciar el servicio en el booteo. Este es el error que me muestra.

Código: Seleccionar todo

oct 31 15:37:14 Palantir noip2[299]: v2.1.9 daemon started with NAT enabled
oct 31 15:37:14 Palantir systemd[1]: Started No-IP Dynamic DNS Update Client.
oct 31 15:37:14 Palantir noip2[299]: Can't gethostbyname for dynupdate.no-ip.com
oct 31 15:37:14 Palantir noip2[299]: Can't get our visible IP address from ip1.dynupdate.no-ip.com
Si reinicio el servicio manualmente actualiza sin problemas.

Estuve buscando un poco y de las soluciones que encontré ninguna me sirvió, al menos me fueron útiles para conocer algunos elementos de Arch, ya que soy nuevo en esta distribución.

En los comentarios del paquete en AUR, hay alguien con el mismo problema, pero la solución que propone no me fue útil: https://aur.archlinux.org/packages/noip/

Estoy usando NetworkManager para la conexión (mediante WIFI), así que modifiqué el archivo del servicio para que se inicie después y marcar como requerido a NetworkManager.

Archivo noip2.service:

Código: Seleccionar todo

[Unit]
Description=No-IP Dynamic DNS Update Client
After=NetworkManager.service
Requires=NetworkManager.service

[Service]
Type=forking
TimeoutStartSec=150
ExecStart=/usr/bin/noip2 -c /etc/no-ip2.conf
Restart=on-failure
RestartSec=30

[Install]
WantedBy=multi-user.target
Pero por lo que entiendo de este listado se sigue ejecutando antes de Networkmanager.

Código: Seleccionar todo

 15.868s mysqld.service
         12.406s httpd.service
         12.234s nmbd.service
          9.824s systemd-journald.service
          6.935s dev-sda3.device
          4.204s NetworkManager.service
          3.607s systemd-logind.service
          3.562s sshdgenkeys.service
          3.561s systemd-user-sessions.service
          2.494s smbd.service
          2.446s polkit.service
          1.666s systemd-journal-flush.service
          1.662s noip2.service
          1.444s systemd-udevd.service
          1.339s systemd-vconsole-setup.service
           768ms systemd-tmpfiles-setup-dev.service
           667ms [email protected]\x2duuid-d39eec0b\x2dac6a\x2d4c5d\x2db90b\x2d13bda042b6ea.service
           635ms wpa_supplicant.service
           406ms systemd-random-seed.service
           340ms dev-disk-by\x2duuid-53c9145e\x2d95f9\x2d4522\x2dbcfb\x2d2dd85cd06571.swap
           340ms systemd-remount-fs.service
           325ms sys-kernel-config.mount
           325ms dev-mqueue.mount
           322ms dev-hugepages.mount
           313ms sys-kernel-debug.mount
           300ms boot.mount
           299ms systemd-tmpfiles-setup.service
           224ms systemd-sysctl.service
           217ms [email protected]
           206ms systemd-udev-trigger.service
           202ms systemd-rfkill.service
           183ms kmod-static-nodes.service
           113ms alsa-restore.service
            95ms systemd-timesyncd.service
            70ms systemd-update-utmp.service
            66ms [email protected]:acpi_video0.service
            30ms tmp.mount
Tengo configurado noip para que verifique la dirección cada 5 minutos, dejé correr el servicio pensado que en la siguiente actualización iba detectar correctamente la dirección IP, ya con NetworkManager corriendo. Pero en este caso el error sigue persistiendo y dando el mismo mensaje.

Acá también proponen otra solución que no funcionó para mi caso: https://bbs.archlinux.org/viewtopic.php?id=156504

Desde lo que conozco de arch y de Linux en general me quedé sin ideas de por donde seguir investigando el problema. Cualquier sugerencia es bienvenida.

Saludos para todos.

Avatar de Usuario
nicros
Equipo Hispano
Equipo Hispano
Mensajes: 815
Registrado: 23 Ago 2006, 10:37
Ubicación: Santiago, Chile

Re: Problema con el Servicio No-ip

Mensaje por nicros » 11 Nov 2015, 16:08

Estimado,

Tuve el mismo problema y tampoco pude solucionarlo de raiz.
Solución drástica, eliminé noip2 e instalé inadyn https://aur.archlinux.org/packages/inadyn-fork/

Espero sea solución.

Saludos,
Por un foro mas ordenado:
Tema: Problema/Consulta [Solucionado]
Reglas del Foro

Responder