Alguien ha instalado el Connector/Python 2.1.3 (mysql-connector-python-2.1.3)

Todo lo relacionado con hacer funcionar a Arch como servidor de lo que sea (pagina web, ftp, archivos, firewall & router, etc...).
Responder
JulioCesar
Novato
Mensajes: 2
Registrado: 21 Nov 2015, 07:00

Alguien ha instalado el Connector/Python 2.1.3 (mysql-connector-python-2.1.3)

Mensaje por JulioCesar » 21 Nov 2015, 07:57

Hola comunidad; hace poco instalé Arch en mi laptop y funciona de maravilla, no he tenido ningún problema con ningún paquete instalando desde pacman o yaourt. No obstante ahora me encuentro con pequeño problema, tengo Python3.5 y estoy aprendiendo django, pero la versión 1.8 de django no es compatible con el mysql-connector-python-2.0.4 que es la ultima versión actual en la repo yaourt.
En la pagina oficial de mysql indican que la versión 2.13 soluciona el problema
http://dev.mysql.com/doc/relnotes/conne ... 2-1-3.html
Estoy tratando de instalar desde pip, pero me sale el siguiente error.

$ sudo pip install http://dev.mysql.com/get/Downloads/Conn ... 1.3.tar.gz

Command "/usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip-gqf4cru2-build/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-9x65kinr-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-gqf4cru2-build

Espero me puedan ayudar. Saludos
JulioCesar

JulioCesar
Novato
Mensajes: 2
Registrado: 21 Nov 2015, 07:00

Re: Alguien ha instalado el Connector/Python 2.1.3 (mysql-connector-python-2.1.3)

Mensaje por JulioCesar » 22 Nov 2015, 20:45

Hola todos, luego de darle algunas vueltas solucioné mi problema descargando e instalando directamente. Al principio tuve unos problemas porque no tenía instalado todos los paquetes base-devel, lo instalé y luego ejecuté el instalador y listo.

$ sudo python setup.py install

Saludos.

Responder