Página 1 de 2

De repente tarda mas de 5 minutos en cargar sistema

Publicado: 12 Nov 2016, 15:18
por ximonarizko
Buenas a [email protected]:
Tengo instalado Archlinux con el entorno XCFE. Hasta hace poco cargaba el sistema en pocos segundos. Desde hace unas semanas, enciendo el ordenador, y tarda como 5 minutos en cargar el entorno grafico. Durante ese tiempo la pantalla se ve negra.

Si en ese periodo de tiempo pulso ctrl+alt F1 (F2, F3...) me sale la consola y puedo logearme. Tambien puedo ejecutar startx y se carga el entorno bien, pero despues de un par de minutos el sistema casca y comienza a hacer parpadeos de un segundo aproximado (pantalla negra... escritorio... pantalla negra...escritorio...).

Si enciendo el PC y lo dejo cargar solo (tarda como 5 minutos, como decia al principio), despues de cargarse el entorno grafico no da ningun problema.

He googleado pero no encuentro ninguna pista. Alguna idea de lo que puede ser?

Que información más podría aportar?

Gracias de antemano!

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 17 Nov 2016, 17:16
por ximonarizko
Alguien puede ayudar a este paquete?

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 22 Nov 2016, 13:20
por tenshal
¿Has probado a revisar el registro de jorunal?
Con persimos de administrador ejecuta lo siguiente en la consola:

Código: Seleccionar todo

journalctl -b -0
Ese comando te mostrará los mensajes del arranque actual. Lee todo el registro e intenta averiguar qué es lo que causa la demora. Los mensajes de advertencia o de errores si mal no recuerdo te aparecerán en color rojo.
Saludos

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 23 Nov 2016, 11:02
por judd
journalctl --verify

systemctl --failed

du /var/log/journal -h

systemd-analyze && systemd-analyze blame

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 23 Nov 2016, 18:42
por ximonarizko
tenshal escribió:¿Has probado a revisar el registro de jorunal?
Con persimos de administrador ejecuta lo siguiente en la consola:

Código: Seleccionar todo

journalctl -b -0
Ese comando te mostrará los mensajes del arranque actual. Lee todo el registro e intenta averiguar qué es lo que causa la demora. Los mensajes de advertencia o de errores si mal no recuerdo te aparecerán en color rojo.
Saludos
Gracias a los dos por responder. En el resultado de journalctl -b -0, la carga empieza a demorar con el siguiente mensaje "localhost.localdomain slim[339]: No protocol specified" se repite cada 2 segundos, durante 4 minutos. He revisado /etc/slim.conf y no veo nada raro, y no me da para mas. Por otra parte, en rojo (con journalctl -b -0) aparecen los siguientes mensajes:
- "Failed to start Sound Service." Aparece 5 veces, pero no tengo problemas con el audio.
- "localhost.localdomain kernel: FAT-fs (sde1): unable to read boot sector to mark fs as"

En cuanto a estos comandos:
judd escribió:journalctl --verify

systemctl --failed

du /var/log/journal -h

systemd-analyze && systemd-analyze blame
- journalctl --verify: en varias ocasiones aparecen en rojo "000000: Invalid tail monotonic timestamp
File corruption detected at /var/log/journal/763813a0d71949b581b87e0dfcc59ccc/[email protected]9487408cb.journal:fffe70 (of 16777216 bytes, 99%)."
- systemctl --failed: "0 loaded units listed."
- du /var/log/journal -h:
"8,0K /var/log/journal/remote
857M /var/log/journal/763813a0d71949b581b87e0dfcc59ccc
857M /var/log/journal"
- systemd-analyze && systemd-analyze blame:
"874ms man-db.service
488ms mnt-datuak.mount
456ms dev-sda5.device
291ms systemd-journal-flush.service
179ms systemd-journald.service
143ms [email protected]\x2duuid-b7675251\x2d73ae\x2d4d9d\x2d90e7\x2d8b0cd521f430.service
109ms NetworkManager.service
103ms home-erabal.mount
97ms systemd-vconsole-setup.service
89ms udisks2.service
83ms upower.service
74ms systemd-modules-load.service
67ms systemd-udevd.service
66ms systemd-logind.service
62ms dev-disk-by\x2duuid-2e6594b2\x2d7541\x2d4787\x2dacfd\x2d9d5cf563155d.swap
59ms systemd-tmpfiles-clean.service
56ms [email protected]
55ms systemd-udev-trigger.service
54ms systemd-binfmt.service
49ms systemd-tmpfiles-setup-dev.service
42ms polkit.service
29ms dev-hugepages.mount
29ms dev-mqueue.mount
26ms sys-kernel-debug.mount
26ms systemd-remount-fs.service
22ms proc-sys-fs-binfmt_misc.mount
18ms logrotate.service
14ms systemd-sysctl.service
14ms rtkit-daemon.service
9ms systemd-tmpfiles-setup.service
7ms tmp.mount
7ms kmod-static-nodes.service
7ms systemd-random-seed.service
6ms alsa-restore.service
6ms systemd-update-utmp.service
5ms systemd-user-sessions.service
2ms sys-fs-fuse-connections.mount
1ms sys-kernel-config.mount"

Alguna idea? Gracias y un saludo!

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 26 Nov 2016, 11:20
por judd
Ejecutalo y luego reinicia:

Código: Seleccionar todo

sudo /usr/bin/mandb
Después:
edita el fichero

Código: Seleccionar todo

/etc/systemd/journald.conf
y modifica la siguiente línea:

Código: Seleccionar todo

SystemMaxUse=50M
Reinicia de nuevo y prueba el comando:

Código: Seleccionar todo

systemd-analyze critical-chain
A ver ahora si mejora....

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 26 Nov 2016, 18:47
por ximonarizko
He seguido los pasos, y al final me responde esto:

graphical.target @1.233s
└─multi-user.target @1.233s
└─getty.target @1.233s
└─[email protected] @1.233s
└─systemd-user-sessions.service @1.226s +4ms
└─network.target @1.212s
└─NetworkManager.service @1.106s +105ms
└─dbus.service @1.046s
└─basic.target @1.045s
└─sockets.target @1.045s
└─dbus.socket @1.045s
└─sysinit.target @1.044s
└─systemd-update-utmp.service @1.037s +6ms
└─systemd-tmpfiles-setup.service @1.026s +9ms
└─local-fs.target @1.012s
└─mnt-datuak.mount @532ms +479ms
└─dev-disk-by\x2duuid-233C9445413B0D3F.device @508ms

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 26 Nov 2016, 18:49
por ximonarizko
Del mensaje anterior, aparecen en rojo estas lineas:
- systemd-user-sessions.service @1.226s +4ms
- NetworkManager.service @1.106s +105ms
- systemd-update-utmp.service @1.037s +6ms
- systemd-tmpfiles-setup.service @1.026s +9ms
- mnt-datuak.mount @532ms +479ms

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 26 Nov 2016, 19:02
por judd
Está todo bien lo que muestras, pero al final mejoró el arranque o no ?

A ver prueba y ponlo aquí:

Código: Seleccionar todo

systemd-analyze

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 26 Nov 2016, 19:48
por judd
ximonarizko escribió:Del mensaje anterior, aparecen en rojo estas lineas:
- systemd-user-sessions.service @1.226s +4ms
- NetworkManager.service @1.106s +105ms
- systemd-update-utmp.service @1.037s +6ms
- systemd-tmpfiles-setup.service @1.026s +9ms
- mnt-datuak.mount @532ms +479ms
Claro, sale en rojo porque te está diciendo lo que más le cuesta cargar en el arranque o carga critica.

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 27 Nov 2016, 15:42
por ximonarizko
El arranque no ha mejorado nada. Este es el resultado desystemd-analyze:

Startup finished in 2.698s (kernel) + 1.334s (userspace) = 4.032s

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 27 Nov 2016, 19:35
por judd
ximonarizko escribió:El arranque no ha mejorado nada. Este es el resultado desystemd-analyze:

Startup finished in 2.698s (kernel) + 1.334s (userspace) = 4.032s
Increible :shock:
Si el sistema te está arrancando en un poco más de 4 segundos es un golaso, ahora tú dices que no ha cambiado nada.....ya escapa a mis conocimientos.

Espero alguien en este foro pueda ayudarte, ahi grandes cerebros aquí, no presisamente el mío.-

Suerte

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 28 Nov 2016, 02:50
por ximonarizko
Te agradezco mucho la ayuda, un saludo!

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 28 Nov 2016, 19:05
por ximonarizko
Aporto más información:
- He sustituido Slim por GDM y la carga ha sido rapida, como lo era antes.
- Cuando he vuelto a habilitar Slim el problema ha vuelto.
- He probado en desinstalar por completo Slim y volver a instalarlo y configurarlo, y el problema sigue igual.

Algo tiene que ver con Slim, pero no se qué...

Re: De repente tarda mas de 5 minutos en cargar sistema

Publicado: 28 Nov 2016, 19:40
por Spooky
Slim es un proyecto abandonado, y de hecho no es del todo compatible con systemd.
Por eso tienes ese problema..

Saludos