Error con pacman 4.0.0.2 Solucionado

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Responder
Avatar de Usuario
kabbalah
Archer Avanzado
Archer Avanzado
Mensajes: 133
Registrado: 03 May 2011, 22:41

Error con pacman 4.0.0.2 Solucionado

Mensaje por kabbalah » 14 Oct 2011, 12:22

Un saludo para todos, sucede que actualice pacman a 4.0.0.2 y luego quise instalar package-query a mano y me da este error

Código: Seleccionar todo

[[email protected] Descargas]$ cd  package-query
[[email protected] package-query]$ ls
PKGBUILD
[[email protected] package-query]$ makepkg -sic PKGBUILD
==> Creando el paquete: package-query 0.9-1 (sáb oct 15 10:18:58 COT 2011)
==> Resolviendo dependencias...
==> Instalando las dependencias que faltan... 
Contraseña: 
atención: desactualizando la versión del paquete pacman (4.0.0-2 => 3.5.4-4)
resolviendo dependencias...
verificando conflictos...

Objetivos (1): pacman-3.5.4-4

Tamaño instalado:       2,78 MiB
Tamaño a actualizar:    -0,21 MiB

¿Continuar con la instalación? [S/n] s
(1/1) verificando la integridad de los paquetes                             [###########################################] 100%
error: pacman: key "F99FFE0FEAE999BD" is unknown
:: Importar la llave PGP EAE999BD, "Allan McRae <[email protected]>", creada 2011-06-03? [S/n] s
(1/1) verificando la integridad de los paquetes                             [###########################################] 100%
error: pacman: signature from "Allan McRae <[email protected]>" is unknown trust
error: error al realizar la transacción (paquete no válido o dañado (firma PGP))
Ocurrieron errores, no se actualizaron paquetes
==> ERROR: 'pacman' fallo al instalar las dependencias faltantes.
Ahora no me funciona yaourt, que puedo hacer?

Gracias

kabbalah
Última edición por kabbalah el 14 Oct 2011, 12:36, editado 1 vez en total.

Avatar de Usuario
kabbalah
Archer Avanzado
Archer Avanzado
Mensajes: 133
Registrado: 03 May 2011, 22:41

Re: Error con pacman 4.0.0.2 Solucionado

Mensaje por kabbalah » 14 Oct 2011, 12:34

Eso de leer antes de preguntar es muy importante, yo baje package-query de aur (Dependencies curl pacman>=3.5 pacman<3.6 yajl>=2.0. Required by laurel-git popular-packages yaour)t, y me dio el error anterior que postee.
Ahí mismo en Aur debajo de package-query esta package-query-git (Dependencies curl pacman>=4 yajl>=2.0. Required by yaourt-git yaourt-git-exp) baje este, lo instale y todo funciona ahora perfectamente.
Espero que este post le sirva alguien.

kabbalah

Responder