Problemas para actualizar [SOLUCIONADO]

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Responder
Avatar de Usuario
tanrax
Archer
Archer
Mensajes: 25
Registrado: 01 Nov 2011, 19:17

Problemas para actualizar [SOLUCIONADO]

Mensaje por tanrax » 01 Nov 2011, 19:20

[[email protected] andros]# yaourt -Syu
:: Sincronizando las bases de datos de paquetes...
core está actualizado
extra está actualizado
community está actualizado
multilib está actualizado
catalyst está actualizado
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
:: catalyst-total: requires xorg-server<1.11.0


Y no me actualiza. Si lo hago con pacman me dice lo mismo. Lleva así un mes y no se que hacer. Por si os sirve de algo: Tengo los repositorios de Any de pacman.

Ayuda por favor. Os lo agradezco por adelantado.
Última edición por tanrax el 02 Nov 2011, 08:25, editado 2 veces en total.

Avatar de Usuario
josejuan
Archer Extremo
Archer Extremo
Mensajes: 320
Registrado: 02 Dic 2010, 08:12
Contactar:

Re: Simplemente.

Mensaje por josejuan » 01 Nov 2011, 19:30

Pues llevas un mes ignorando el error que te indica :)
catalyst-total: requires xorg-server<1.11.0
Ten en cuenta que pacman no va a poder actualizar catalyst porque no hay posible versión y te está diciendo que el paquete que tienes instalado de ATI necesita una versión anterior a la 1.11 de las X.

Como (casi seguro) instalaste las catalyst con pacman -U catalyst...xz tienes dos opciones:

1. downgradar tus X a la 1.10.

2. mirar a ver si hay una nueva versión de las catalyst para las nuevas X.

:wink:

Avatar de Usuario
tanrax
Archer
Archer
Mensajes: 25
Registrado: 01 Nov 2011, 19:17

Re: Simplemente.

Mensaje por tanrax » 01 Nov 2011, 19:44

Antes de nada: mil gracias por tomarte la molestia de contestarme.

[email protected] andros]# Xorg -version

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.0-ARCH x86_64
Current Operating System: Linux myhost 3.0-ARCH #1 SMP PREEMPT Fri Oct 7 11:35:34 CEST 2011 x86_64
Kernel command line: root=/dev/sda5 ro
Build Date: 17 September 2011 07:42:58AM

Current version of pixman: 0.22.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.


No tendría que pedirme una versión anterior a la 1.11, porque ya la tengo ¿no?

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: Simplemente.

Mensaje por madek » 01 Nov 2011, 20:51

revisa la version del paquete xorg-server, nada mas que eso

pd: titulo mas descriptivo para la otra por favor, o el post podria aparecer magicamente con un candadito
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

Avatar de Usuario
tanrax
Archer
Archer
Mensajes: 25
Registrado: 01 Nov 2011, 19:17

Re: Simplemente.

Mensaje por tanrax » 01 Nov 2011, 21:16

Perdona mi ignorancia, pero ¿como lo reviso?

Avatar de Usuario
FedeTheGreat
Equipo Hispano
Equipo Hispano
Mensajes: 3574
Registrado: 01 Abr 2007, 12:03
Ubicación: Victoria - Buenos Aires - Argentina
Contactar:

Re: Problemas para actualizar

Mensaje por FedeTheGreat » 01 Nov 2011, 21:43

Código: Seleccionar todo

# pacman -Qs xorg-server
local/xorg-server 1.11.1.902-1 (xorg)
    Xorg X server
local/xorg-server-common 1.11.1.902-1
    Xorg server common files
local/xorg-server-utils 7.6-2
    Transition package depending on xorg server utilities
Me gustan las cosas simples por eso uso Arch!
Linux User# 404818
Nos vemos en irc.freenode.net #archlinux-es
Canal de discusión en Español

Avatar de Usuario
tanrax
Archer
Archer
Mensajes: 25
Registrado: 01 Nov 2011, 19:17

Re: Problemas para actualizar

Mensaje por tanrax » 02 Nov 2011, 04:39

[[email protected] andros]# pacman -Qs xorg-server
local/xorg-server 1.10.4-1 (xorg)
Xorg X server
local/xorg-server-common 1.10.4-1
Xorg server common files
local/xorg-server-utils 7.6-2
Transition package depending on xorg server utilities


¿Y ahora qué?

Avatar de Usuario
josejuan
Archer Extremo
Archer Extremo
Mensajes: 320
Registrado: 02 Dic 2010, 08:12
Contactar:

Re: Problemas para actualizar

Mensaje por josejuan » 02 Nov 2011, 06:46

y dale, que no, lo que te está diciendo pacman es que:

no puede actualizar el sistema

¿porqué no?

porque si lo hace, tu paquete catalyst dejaría de funcionar

¿porqué?

porque el paquete que tienes instalado requiere una versión de xorg<=1.11 y la que pacman quiere instalar es la 16 (así de memoria)

sí, tienes instalada la xorg 1.10 ¡pero pacman quiere instalar la 16!

:wink:

Avatar de Usuario
tanrax
Archer
Archer
Mensajes: 25
Registrado: 01 Nov 2011, 19:17

Re: Problemas para actualizar

Mensaje por tanrax » 02 Nov 2011, 08:24

SOLUCIONADO

Volví a instalar el catalyst con yaourt pero quitando la dependencia de xorg-server.

Mil gracias a todos. Sois geniales.

Responder