SOLUCIONADO Error al hacer pacman -Syu

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Responder
enric
Novato
Mensajes: 10
Registrado: 13 Nov 2011, 18:53

SOLUCIONADO Error al hacer pacman -Syu

Mensaje por enric » 16 Ene 2012, 19:46

Hola buenas, necesito ayuda. Hoy al actualizar el sistema con pacman -Syu, el sistema me da este error que no se como arreglarlo.
Un saludo y gracias por vuestra ayuda.

b]¿Continuar con la instalación? [S/n] s
(16/16) verificando la integridad de los paquetes [----------------------------------] 100%
error: gmime: signature from "Ionut Biru <[email protected]>" is unknown trust
error: gvfs: signature from "Dave Reisner <[email protected]>" is unknown trust
error: libreoffice-es: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-common: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-base: signature from "Andreas Radke <[email protected]>" is unk[nown trust
error: libreoffice-calc: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-draw: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-gnome: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-impress: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-kde4: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-math: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-sdk: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-sdk-doc: signature from "Andreas Radke <[email protected]>" is unknown trust
error: libreoffice-writer: signature from "Andreas Radke <[email protected]>" is unknown trust
error: sdl_image: signature from "Jan Alexander Steffens (heftig) <[email protected]>" is unknown trust
error: totem-plparser: signature from "Ionut Biru <[email protected]>" is unknown trust
error: error al realizar la transacción (paquete no válido o dañado (firma PGP))
Ocurrieron errores, no se actualizaron paquetes
[/b]
Última edición por enric el 17 Ene 2012, 15:34, editado 2 veces en total.

ridri
Archer Avanzado
Archer Avanzado
Mensajes: 117
Registrado: 28 Sep 2011, 18:34

Re: Error al hacer pacman -Syu

Mensaje por ridri » 16 Ene 2012, 20:05

El problema puede ser que se acaba de añadir pacman-4 a core y a parte según he leido en el foro en inglés hay problemas con la sincronización de mirrors. Quizás sea mejor esperar algunas horas para actualizar: https://bbs.archlinux.org/viewtopic.php?id=133684 https://bbs.archlinux.org/viewtopic.php?id=133683
Al parecer con pacman-4 ya tenemos los paquetes con claves de autentificación y echaremos de menos las críticas a arch. Por ahora vienen desactivadas por defecto. Habrá que toquetear el archivo /etc/pacman.conf.pacnew http://www.archlinux.org/news/pacman-4-moves-to-core/

mundigranja
Archer Intermedio
Archer Intermedio
Mensajes: 68
Registrado: 18 Sep 2010, 10:12
Contactar:

Re: Error al hacer pacman -Syu

Mensaje por mundigranja » 16 Ene 2012, 20:21

Como te dice ridri es bueno leer los anuncios en la página oficial [1] y la wiki [2]

Probablemente debas ejecutar:

Código: Seleccionar todo

# pacman-key --init
y/o añadir a /etc/pacman.conf alguna de las líneas siguientes:

Código: Seleccionar todo

SigLevel     = Required TrustAll
SigLevel     = Optional TrustAll
[1] http://www.archlinux.org/news/pacman-4-moves-to-core/
[2] https://wiki.archlinux.org/index.php/Pacman-key

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: Error al hacer pacman -Syu

Mensaje por madek » 16 Ene 2012, 20:51

estoy preparando una pequeña guia para el proceso de actualizacion a pacman 4, esperen un ratito

edit: http://www.foros.archlinux-es.org/viewt ... f=5&t=5563
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

Avatar de Usuario
essau
Archer Avanzado
Archer Avanzado
Mensajes: 139
Registrado: 11 Oct 2011, 09:22
Ubicación: Europa, España, Madrid.

Re: Error al hacer pacman -Syu

Mensaje por essau » 17 Ene 2012, 06:14

Código: Seleccionar todo

:: Los siguientes paquetes deben actualizarse primero:
    pacman
:: ¿Desea cancelar la operación actual
:: y actualizar estos paquetes ahora? [S/n] 

resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: packagekit: necesita pacman<3.6.0
:: package-query: necesita pacman<3.6
:: pacman-color: necesita pacman<3.6
:: pkgbrowser: necesita pacman<4
[email protected]~# 
:oops:

Avatar de Usuario
cargoan
Archer Confiable
Archer Confiable
Mensajes: 605
Registrado: 13 Mar 2011, 04:39

Re: Error al hacer pacman -Syu

Mensaje por cargoan » 17 Ene 2012, 10:56

Yo he seguido esta guía https://archtesting.wordpress.com/2011/ ... de-pacman/ y me ha ido bien.
«La simplicidad es la máxima sofisticación» (Leonardo da Vinci)

IcedR
Archer Intermedio
Archer Intermedio
Mensajes: 63
Registrado: 14 Ago 2010, 01:16

Re: Error al hacer pacman -Syu

Mensaje por IcedR » 17 Ene 2012, 13:58

Con los pasos de la guía me ha ido bien. De hecho, instaló sin problemas. Ahora, a seguir con la actualización.
Gracias!

Avatar de Usuario
essau
Archer Avanzado
Archer Avanzado
Mensajes: 139
Registrado: 11 Oct 2011, 09:22
Ubicación: Europa, España, Madrid.

Re: Error al hacer pacman -Syu

Mensaje por essau » 17 Ene 2012, 15:07

gracias gargoan,
algo así se me ocurrió hacer, desistalar los archivos esos que me bloqueaban la actualización de pacman, y luego instalar pacman. He tenido que hacer lógicamente todo el asunto de importación de llaves PGP y eso que conlleva pacman 4, y luego he instalado lo que había desistalado al principio. Todo OK.
:mrgreen:

enric
Novato
Mensajes: 10
Registrado: 13 Nov 2011, 18:53

Solución al error al hacer pacman -Syu

Mensaje por enric » 17 Ene 2012, 15:31

Hola, gracias a todos por vuestra respuestas. Al final, añadí en el archivo /etc/pacman.conf la opción SigLevel = Optional TrustAll, tal como indica mundigranja y ya he podido actualizar.
Gracias a todos por vuestro interés. Un saludo,

xfaker
Archer
Archer
Mensajes: 43
Registrado: 12 Feb 2011, 09:30

Re: Error al hacer pacman -Syu

Mensaje por xfaker » 17 Ene 2012, 18:32

essau escribió:

Código: Seleccionar todo

:: Los siguientes paquetes deben actualizarse primero:
    pacman
:: ¿Desea cancelar la operación actual
:: y actualizar estos paquetes ahora? [S/n] 

resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: packagekit: necesita pacman<3.6.0
:: package-query: necesita pacman<3.6
:: pacman-color: necesita pacman<3.6
:: pkgbrowser: necesita pacman<4
[email protected]~# 
:oops:
Tengo el mismo error:

Código: Seleccionar todo


$ pacman -Syu
Contraseña: 

:: Sincronizando las bases de datos de paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
 archlinuxfr está actualizado
:: Los siguientes paquetes deben actualizarse primero:
    pacman
:: ¿Desea cancelar la operación actual
:: y actualizar estos paquetes ahora? [S/n] 

resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: package-query: necesita pacman<3.6
La guia que posteo cargoan me sirvio, lo unico que tuve que hacer las cosas desde una tty, ya que el emulador de terminal que uso ](lilyterm) no siempre anda bien cuando uso sudo...

Avatar de Usuario
sud_crow
Administrador
Administrador
Mensajes: 952
Registrado: 16 Abr 2005, 00:38
Ubicación: Buenos Aires - Argentina
Contactar:

Re: SOLUCIONADO Error al hacer pacman -Syu

Mensaje por sud_crow » 18 Ene 2012, 13:57

xfaker escribió:
essau escribió:

Código: Seleccionar todo

:: Los siguientes paquetes deben actualizarse primero:
 pacman
:: ¿Desea cancelar la operación actual
:: y actualizar estos paquetes ahora? [S/n] 

resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: packagekit: necesita pacman<3.6.0
:: package-query: necesita pacman<3.6
:: pacman-color: necesita pacman<3.6
:: pkgbrowser: necesita pacman<4
[email protected]~# 
:oops:
Tengo el mismo error:

Código: Seleccionar todo


$ pacman -Syu
Contraseña: 

:: Sincronizando las bases de datos de paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
 archlinuxfr está actualizado
:: Los siguientes paquetes deben actualizarse primero:
 pacman
:: ¿Desea cancelar la operación actual
:: y actualizar estos paquetes ahora? [S/n] 

resolviendo dependencias...
verificando conflictos...
error: error al preparar la transacción (no se pudieron satisfacer las dependencias)
:: package-query: necesita pacman<3.6
La guia que posteo cargoan me sirvio, lo unico que tuve que hacer las cosas desde una tty, ya que el emulador de terminal que uso ](lilyterm) no siempre anda bien cuando uso sudo...
Esto es otro problema del reportado en el original.
Lo tuyo es un tema de incompatibilidad de versiones (tenes paquetes no oficiales, q no soportan pacman 4).
Lo del tema original, es un tema de las llaves de encriptado implementado en pacman 4.

xfaker, si seguís teniendo el inconveniente publica en otro hilo por favor!

Saludos!
¿Revisaste la wiki? | ¿Usaste la función buscar del foro? | ¿Leíste las normas del foro?
Blog : | Correo+Jabber: leonardo @ archlinux-es.org

Avatar de Usuario
MarcMiralles
Archer Extremo
Archer Extremo
Mensajes: 198
Registrado: 18 Dic 2011, 20:36
Ubicación: España
Contactar:

Re: SOLUCIONADO Error al hacer pacman -Syu

Mensaje por MarcMiralles » 18 Ene 2012, 16:37

UFFFF!!!!, vaya susto!!!!!
No te estreses, !usa Linux!

Mi blog de CinnArch, Arch, y programación en c++ Qt, Vala GTK+ y software libre.
http://milinuxblog.terramedicsoft.com

Responder