Error para actualizar [Solucionado]

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Responder
IcedR
Archer Intermedio
Archer Intermedio
Mensajes: 63
Registrado: 14 Ago 2010, 01:16

Error para actualizar [Solucionado]

Mensaje por IcedR » 17 Ene 2012, 00:41

Holas! Me encontraba yo sentado cómodamente frente a mi computador con Arch, y decidí actualizar. De primera me dijo que, para hacer tal, debía actualizar pacman (de 3.5 a 3.6). Pero, ahora no puedo hacer funcionar pacman! Me llora por un archivo, me lanza el siguiente error:

Código: Seleccionar todo

pacman: error while loading shared libraries: libarchive.so.12: cannot open shared object file: No such file or directory
Cómo soluciono eso? No tengo idea de qué hacer, primera vez que me enfrento a esto :S
Última edición por IcedR el 17 Ene 2012, 13:59, editado 1 vez en total.

nyko123
Novato
Mensajes: 7
Registrado: 22 Ago 2011, 23:30

Re: Error para actualizar

Mensaje por nyko123 » 17 Ene 2012, 00:45

A mi me paso algo parecido recien. Fijate si no podes reinstalar pacman como dice la wiki https://wiki.archlinux.org/index.php/Pa ... tall_it.3F. Yo probe con el ultimo pero sigue sin funcionar. Acabo de crear el tema justo antes que vos http://www.foros.archlinux-es.org/viewt ... f=5&t=5564

IcedR
Archer Intermedio
Archer Intermedio
Mensajes: 63
Registrado: 14 Ago 2010, 01:16

Re: Error para actualizar

Mensaje por IcedR » 17 Ene 2012, 13:59

http://www.foros.archlinux-es.org/viewt ... f=5&t=5562

En este post aparece una guía, que fue la que finalmente seguí. Me dejó instalar pacman de nuevo. Ahora estoy batallando con pacman 4, pero supongo que este post ya está solucionado. Gracias de todas maneras!

Responder