error al actualizar a pacman 4 [solucionado]

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Avatar de Usuario
alfplayer
Archer Confiable
Archer Confiable
Mensajes: 479
Registrado: 19 Nov 2010, 13:39
Ubicación: Buenos Aires, Argentina
Contactar:

Re: error al actualizar a pacman 4

Mensaje por alfplayer » 22 Ene 2012, 17:11

Sí, me parece bien también.

Qué pacman estás usando? Cómo lo instalaste?
Parabola GNU/Linux-libre - basada en Arch - distribución libre según el Proyecto GNU.

Avatar de Usuario
AALD666
Archer Extremo
Archer Extremo
Mensajes: 170
Registrado: 23 Dic 2010, 23:41
Contactar:

Re: error al actualizar a pacman 4

Mensaje por AALD666 » 22 Ene 2012, 17:26

pues el viernes, iba a actualizar con -Syu y me salio el error de que pacman debia actualizar a la version 4, vi que esta vez era algo diferente, y encontre este tutorial:

http://usemoslinux.blogspot.com/2012/01 ... ucion.html

comence con el proceso, pero me daba cuenta de que no me generaba el pacman.conf nuevo, y eso me daba un monton de errores a la hora de hacer cualquier actividad con pacman, despues de actualizar varias veces pacman y seguir con el mismo problema, me desespere y desinstale pacman con un brutal -Rsc y ahora desde ese mismo dia he intentado instalar el pacman 4 desde su codigo fuente pero me salen errores tambien, mira el otro post mio donde muestro los errores:

http://www.foros.archlinux-es.org/viewt ... f=5&t=5584

en la pagina oficial de pacman, dice que solo basta con hacer ./configure, make y make install

igual, no se si esta bien, pero el fichero .pkg.tar.gz lo descomprimi y copie las carpetas a la raiz, etc, var, y usr (creo que son esas no me acuerdo)
y ahora cuando intento hacer cualquier cosa con pacman me sale lo siguiente que ya habia mencionado anteriormente:

Código: Seleccionar todo

error: no hay ningún repositorio de paquetes configurado.

Avatar de Usuario
AALD666
Archer Extremo
Archer Extremo
Mensajes: 170
Registrado: 23 Dic 2010, 23:41
Contactar:

Re: error al actualizar a pacman 4

Mensaje por AALD666 » 22 Ene 2012, 17:46

parece que no tengo mas alternativa que reinstalar todo el sistema no?

pero quisiera despejar algunas dudad primero.

yo tengo la particion /home / /boot /swap todas separadas

¿puedo utilizar el liveUSB para reinstalar solamente lo de la particion raiz /?
¿como lo hago?

Avatar de Usuario
alfplayer
Archer Confiable
Archer Confiable
Mensajes: 479
Registrado: 19 Nov 2010, 13:39
Ubicación: Buenos Aires, Argentina
Contactar:

Re: error al actualizar a pacman 4

Mensaje por alfplayer » 22 Ene 2012, 18:54

Yo intentaría ejecutando manualmente el PKGBUILD y el archivo .install de pacman. Se pueden obtener de http://mirrors.kernel.org/archlinux/sou ... src.tar.gz
Parabola GNU/Linux-libre - basada en Arch - distribución libre según el Proyecto GNU.

Avatar de Usuario
AALD666
Archer Extremo
Archer Extremo
Mensajes: 170
Registrado: 23 Dic 2010, 23:41
Contactar:

Re: error al actualizar a pacman 4

Mensaje por AALD666 » 23 Ene 2012, 12:51

y como se hace eso?

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: error al actualizar a pacman 4

Mensaje por madek » 23 Ene 2012, 13:01

Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

Avatar de Usuario
AALD666
Archer Extremo
Archer Extremo
Mensajes: 170
Registrado: 23 Dic 2010, 23:41
Contactar:

Re: error al actualizar a pacman 4

Mensaje por AALD666 » 23 Ene 2012, 13:14

esa era la solucion!

aunque tuve que editar el fichero porque estaba muy viejo, para que descargara las versiones adecuadas:

Código: Seleccionar todo

#!/bin/bash

arch=i686
mirror=http://mirror.rit.edu/archlinux

# link to cache (or download) and extract: openssl,libarchive,libfetch,pacman
cd /tmp
for pkg in openssl-1.0.0.g-1 libarchive-3.0.3-2 libfetch-2.33-3 pacman-4.0.1-4; do
    pkgname=${pkg}-${arch}.pkg.tar.gz
    if [[ -e /var/cache/pacman/pkg/${pkgname} ]]; then
        ln -sf /var/cache/pacman/pkg/${pkgname} .
    else
        wget ${mirror}/core/os/${arch}/${pkgname} || exit 1
    fi
    sudo tar -xvpf ${pkgname} -C / --exclude .PKGINFO --exclude .INSTALL || exit 1
done

# now reinstall using pacman to update the local pacman db 
sudo pacman -Sf openssl libarchive libfetch pacman || exit 1

# now update your system
sudo pacman -Syu
al fin lo solucione!

muchas gracias

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: error al actualizar a pacman 4

Mensaje por madek » 23 Ene 2012, 13:59

recuerda hacer al final del proceso un pacman -Sf openssl libarchive libfetch pacman para que pacman aparezca como instalado en la base de datos
y tambien recuerda marcar el primer post como solucionado
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

Responder