base de datos no válida o dañada (firma PGP) [SOLUCIONADO]

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Responder
mordiskos
Novato
Mensajes: 10
Registrado: 10 Abr 2013, 20:14

base de datos no válida o dañada (firma PGP) [SOLUCIONADO]

Mensaje por mordiskos » 04 Ene 2014, 08:38

Buenos dias,

Llevo desde hace unos dias con un problema que me trae de cabeza, no puedo actualizar el sistema ni instalar programas, etc...

Creo que el problema estubo originado en su momento por los repositorios de catalyst, pero los cambié, tal como dijo VI0L0 (quien mantiene el repositorio). Y aun asi, sigo sin poder actulizar, os dejo un copy&paste de lo que me pasa:

Código: Seleccionar todo

error: GPGME error: No data
:: Sincronizando las bases de datos de paquetes...
 catalyst-stable está actualizado
 core está actualizado
 extra                          1440,5 KiB  1559K/s 00:01 [##############################] 100%
 community                         2,0 MiB  1555K/s 00:01 [##############################] 100%
 multilib                        109,7 KiB   686K/s 00:00 [##############################] 100%
 archlinuxfr está actualizado
 catalyst-stable                  10,4 KiB  73,7K/s 00:00 [##############################] 100%
 catalyst-stable.sig              10,4 KiB  1732K/s 00:00 [##############################] 100%
error: GPGME error: No data
error: error al actualizar catalyst-stable (base de datos no válida o dañada (firma PGP))
error: la base de datos 'catalyst-stable' no es válida (base de datos no válida o dañada (firma PGP))
Un saludo!
Última edición por mordiskos el 05 Ene 2014, 14:29, editado 1 vez en total.

Avatar de Usuario
davidlghellin
Archer Avanzado
Archer Avanzado
Mensajes: 112
Registrado: 09 Mar 2012, 10:53
Ubicación: Albacete, España

Re: base de datos no válida o dañada (firma PGP)

Mensaje por davidlghellin » 04 Ene 2014, 09:35

intenta borrar esos paquetes de la base de datos y volver a descargaros, así lo solucione yo una vez
buscalos en

Código: Seleccionar todo

/var/cache/pacman/pkg
Si existiera la certeza no estaría la estadística
Usuario Linux #553802

mordiskos
Novato
Mensajes: 10
Registrado: 10 Abr 2013, 20:14

Re: base de datos no válida o dañada (firma PGP)

Mensaje por mordiskos » 05 Ene 2014, 10:34

He limpiado de la cache, los paquetes antiguos, y he dejado unicamente los de las versiones instaladas, con el siguiente comando:

Código: Seleccionar todo

pacman -Sc
No se si te referias a esto? He buscado dentro de esa carpeta pero no encuentro ningun fichero que se llame o tenga en su nombre "catalyst". Cuales deberia eliminar?

Un saludo!

mordiskos
Novato
Mensajes: 10
Registrado: 10 Abr 2013, 20:14

Re: base de datos no válida o dañada (firma PGP)

Mensaje por mordiskos » 05 Ene 2014, 10:47

Bueno, ya lo he solucionado...Ha sido un GRAN fallo por mi parte:

En /etc/pacman.conf tenia el repositorio para xorg 1.13 y mas abajo el de catalyst-stable. Cambié el repositorio de xorg1.13 por el mirror actualizado, pero se me olvidó cambiar el de catalyst-stable (que estaba al final del fichero)...

En fin, que muchas gracias por la ayuda, voy a ver si me flagelo un poco... :cry:

Avatar de Usuario
cuentos
Equipo Hispano
Equipo Hispano
Mensajes: 544
Registrado: 25 Mar 2012, 03:24
Contactar:

Re: base de datos no válida o dañada (firma PGP)

Mensaje por cuentos » 05 Ene 2014, 12:35

Bueno que encontraste la solución, solo te resta editar el primer hilo y agregar (SOLUCIONADO).
El [SOLUCIONADO] se pone luego de resolver el problema y que se realiza editando el post original.
Siempre se debe colocar al final del titulo, permitiendo leer cual era el problema antes.
twitter @mcuentos

Responder