Problema al actualizar Arch

Para que opines sobre pacman o comentes problemas instalando algún paquete.
Responder
Avatar de Usuario
AALD666
Archer Extremo
Archer Extremo
Mensajes: 170
Registrado: 23 Dic 2010, 23:41
Contactar:

Problema al actualizar Arch

Mensaje por AALD666 » 04 Mar 2014, 11:18

Hola a [email protected]

Tengo este problema cuando intente actualizar mi Arch el día de hoy, con el pacman me salio todo perfecto pero cuando intento actualizar los paquetes de Arch tengo estos errores con estos paquetes: :oops:

Código: Seleccionar todo

==> Sólo actualización del paquete (nuevo lanzamiento):
extra/libunique    1.1.6-5   5 -> 6
extra/orbit2       2.14.19-2 2 -> 3

==> Actualización del programa (nueva versión):
aur/perl-mouse     1.11-1    -> 2.1.0-1
aur/perl-yaml-tiny 1.51-2    -> 1.61-1

==> Continuar con la actualización? [S/n]
==> [V]isualizar los detalles del paquete   Selección [M]anual de los paquetes
==> --------------------------------------------------------------------------
==> :: Iniciando actualización completa del sistema...
resolviendo dependencias...
verificando conflictos...

Paquetes (2): libunique-1.1.6-6  orbit2-2.14.19-3

Tamaño Total de Descarga:  0,27 MiB
Tamaño Total Instalado:    1,82 MiB
Tamaño neto a actualizar:  -0,21 MiB

:: ¿Continuar con la instalación? [S/n] 
:: Recuperando paquetes ...
--2014-03-04 09:11:03--  http://mirror.us.leaseweb.net/archlinux/extra/os/i686/libunique-1.1.6-6-i686.pkg.tar.xz
Resolviendo mirror.us.leaseweb.net (mirror.us.leaseweb.net)... 108.59.10.97, 2604:9a00:2010:a001:1:face:bad:c0de
Conectando con mirror.us.leaseweb.net (mirror.us.leaseweb.net)[108.59.10.97]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 26664 (26K) [application/octet-stream]
Grabando a: “/var/cache/pacman/pkg/libunique-1.1.6-6-i686.pkg.tar.xz.part”

100%[==================================================================================================>] 26.664       104KB/s   en 0,3s   

2014-03-04 09:11:03 (104 KB/s) - “/var/cache/pacman/pkg/libunique-1.1.6-6-i686.pkg.tar.xz.part” guardado [26664/26664]

--2014-03-04 09:11:03--  http://mirror.us.leaseweb.net/archlinux/extra/os/i686/orbit2-2.14.19-3-i686.pkg.tar.xz
Resolviendo mirror.us.leaseweb.net (mirror.us.leaseweb.net)... 108.59.10.97, 2604:9a00:2010:a001:1:face:bad:c0de
Conectando con mirror.us.leaseweb.net (mirror.us.leaseweb.net)[108.59.10.97]:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 258620 (253K) [application/octet-stream]
Grabando a: “/var/cache/pacman/pkg/orbit2-2.14.19-3-i686.pkg.tar.xz.part”

100%[==================================================================================================>] 258.620      288KB/s   en 0,9s   

2014-03-04 09:11:04 (288 KB/s) - “/var/cache/pacman/pkg/orbit2-2.14.19-3-i686.pkg.tar.xz.part” guardado [258620/258620]

(2/2) verificando llaves en el llavero                                               [################################################] 100%
(2/2) verificando la integridad de los paquetes                                      [################################################] 100%
(2/2) cargando los archivos del paquete...                                           [################################################] 100%
(2/2) verificando conflictos entre archivos                                          [################################################] 100%
(2/2) verificando el espacio disponible en disco                                     [################################################] 100%
(1/2) actualizando libunique                                                         [################################################] 100%
(2/2) actualizando orbit2                                                            [################################################] 100%

==> Descargando PKGBUILD desde AUR...
x PKGBUILD
Comment by vendion  (2014-02-28 12:37)
When trying to build the new version I get the following error:

== Making package: perl-mouse 2.1.0-1 (Fri Feb 28 07:34:08 EST 2014)
== Checking runtime dependencies...
== Checking buildtime dependencies...
== Retrieving sources...
- Downloading Mouse-2.1.0.tar.gz...
% Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
Dload  Upload   Total   Spent    Left  Speed
0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  214k  100  214k    0     0   129k      0  0:00:01  0:00:01 --:--:--  274k
== Validating source files with md5sums...
Mouse-2.1.0.tar.gz ... Passed
== Extracting sources...
- Extracting Mouse-2.1.0.tar.gz with bsdtar
== Starting build()...
Base class package "Module::Build::XSUtil" is empty.
(Perhaps you need to 'use' the module which defines that package first,
or make that module available in @INC (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .).
at builder/MyBuilder.pm line 6.
BEGIN failed--compilation aborted at builder/MyBuilder.pm line 6.
Compilation failed in require at Build.PL line 12.
BEGIN failed--compilation aborted at Build.PL line 12.
== ERROR: A failure occurred in build().
Aborting...

Comment by FernandoBasso  (2014-03-02 09:57)
Same problem as @vendion.

Comment by dennis123123  (2014-03-02 10:22)
Also same problem as @vendion.

Comment by siliconmeadow  (2014-03-03 05:23)
Same here. I might be wrong, but it seems to be looking for this:

http://search.cpan.org/~gfuji/Module-Install-XSUtil-0.45/

which I can't find in AUR. Something's up with CPAN for me too, I can seem to get it to work from the command line. Because of this, I wasn't able to verify.

Comment by hermes14  (2014-03-03 16:47)
It's Module-Build-XSUtil (http://search.cpan.org/~hideakio/Module-Build-XSUtil-0.06/)
It works now.
I can provide a PKGBUILD for it, but I can't maintain it, since I'm no perl expert at all.

perl-mouse 2.1.0-1  (dom sep 21 18:44:25 COT 2008)
(Paquete sin soporte: podría ser peligroso!)
==> dependencias de perl-mouse:
 - perl>=5.6.2 (ya instalado)
 - perl-test-exception (ya instalado)
 - perl-test-fatal (ya instalado)
 - perl-module-build (ya instalado)


==> Continuar compilando perl-mouse? [S/n]
==> --------------------------------------
==> 
==> Compilando e instalando el paquete
==> Creando el paquete: perl-mouse 2.1.0-1 (mar mar  4 09:11:11 COT 2014)
==> Resolviendo dependencias...
==> Verificando conflictos...
==> Recibiendo fuentes...
  -> Descargando Mouse-2.1.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  214k  100  214k    0     0   111k      0  0:00:01  0:00:01 --:--:--  444k
==> Validando el archivo fuente con md5sums...
    Mouse-2.1.0.tar.gz ... Aprobado
==> Descomprimiendo fuentes...
  -> Extrayendo Mouse-2.1.0.tar.gz con bsdtar
==> Iniciando build()...
Base class package "Module::Build::XSUtil" is empty.
    (Perhaps you need to 'use' the module which defines that package first,
    or make that module available in @INC (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .).
 at builder/MyBuilder.pm line 6.
BEGIN failed--compilation aborted at builder/MyBuilder.pm line 6.
Compilation failed in require at Build.PL line 12.
BEGIN failed--compilation aborted at Build.PL line 12.
==> ERROR: Se produjo un error en build().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar perl-mouse.
==> Reiniciar la compilación de perl-mouse? [s/N]
==> ---------------------------------------------
==> 
==> ERROR: no se puede actualizar

==> Descargando PKGBUILD desde AUR...
x PKGBUILD
Comment by samuellittley  (2013-04-14 19:38)
Should be fixed, I think something changed in makepkg that broke it...

Comment by msx  (2013-11-11 05:41)
Thanks for the package!

Comment by FadeMind  (2014-02-28 12:39)
Something is missing? 

Failed build:

Zaczynam build()
Creating new 'Build' script for 'YAML-Tiny' version '1.61'
cp lib/YAML/Tiny.pm blib/lib/YAML/Tiny.pm
== Zaczynam check()
Can't locate TAP/Harness/Env.pm in @INC (you may need to install the TAP::Harness::Env module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/perl5/vendor_perl/Module/Build/Tiny.pm line 103.
== BŁĄD: Wystąpił błąd w check().
Przerywam...
== ERROR: Makepkg was unable to build perl-yaml-tiny.

Bug: https://bugzilla.redhat.com/show_bug.cgi?id=1067098

Comment by FernandoBasso  (2014-03-02 09:56)
Same problem as @FadeMind.

Comment by hermes14  (2014-03-03 16:20)
Installing Test-Harness and Test-Simple does the trick.
I can provide two basic PKGBUILDs if you wish, but I'm no perl expert, so I cannot maintain any of them, sorry.

perl-yaml-tiny 1.61-1  (lun ago  6 15:16:56 COT 2007)
(Paquete sin soporte: podría ser peligroso!)
==> dependencias de perl-yaml-tiny:
 - perl>=5.004 (ya instalado)
 - perl-module-build-tiny (ya instalado)


==> Continuar compilando perl-yaml-tiny? [S/n]
==> ------------------------------------------
==> 
==> Compilando e instalando el paquete
==> Creando el paquete: perl-yaml-tiny 1.61-1 (mar mar  4 09:11:18 COT 2014)
==> Resolviendo dependencias...
==> Verificando conflictos...
==> Recibiendo fuentes...
  -> Descargando YAML-Tiny-1.61.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 71703  100 71703    0     0  63018      0  0:00:01  0:00:01 --:--:--  208k
==> Validando el archivo fuente con md5sums...
    YAML-Tiny-1.61.tar.gz ... Aprobado
==> Descomprimiendo fuentes...
  -> Extrayendo YAML-Tiny-1.61.tar.gz con bsdtar
==> Iniciando build()...
Creating new 'Build' script for 'YAML-Tiny' version '1.61'
cp lib/YAML/Tiny.pm blib/lib/YAML/Tiny.pm
==> Iniciando check()...
Can't locate TAP/Harness/Env.pm in @INC (you may need to install the TAP::Harness::Env module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/perl5/vendor_perl/Module/Build/Tiny.pm line 103.
==> ERROR: Se produjo un error en check().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar perl-yaml-tiny.
==> Reiniciar la compilación de perl-yaml-tiny? [s/N]
==> -------------------------------------------------
==> 
==> ERROR: no se puede actualizar
==> actualizando el paquete SVN/CVS/HG/GIT
Agradezco sus ayudas :P

Avatar de Usuario
AALD666
Archer Extremo
Archer Extremo
Mensajes: 170
Registrado: 23 Dic 2010, 23:41
Contactar:

Re: Problema al actualizar Arch

Mensaje por AALD666 » 04 Mar 2014, 11:22

Otra cosa que olvide mencionar es que despues de esto no tengo audio en el PC, o si tengo pero durante unos minutos despues de encender la PC y despues de un momento ya no me funciona el audio :roll:

Responder