[SOLUCIONADO] "No hay regla para construir"

Dudas al crear un paquete? cualquier problema que tengas con makepkg comentalo aca!
Responder
Avatar de Usuario
Einki
Archer
Archer
Mensajes: 22
Registrado: 05 Feb 2011, 15:43

[SOLUCIONADO] "No hay regla para construir"

Mensaje por Einki » 23 Oct 2011, 15:51

Buenas tardes chicos, sucede que estoy reinstalando mi sistema, ahora me encuentro reinstalado la tarjeta inalámbrica, es una BCM4312, estoy reinstalando a través de los paquetes de AUR, pero me sale un detalle que es "no hay regla para construir", a qué se refiere, me imagino que algo me hace falta, pero aún no doy qué es.

Tengo todo el base-devel instalado, (hasta lo reinstalé).


Agradezco su apoyo.

Adjunto parte del código del error:

Código: Seleccionar todo

...
  -> Se encontró modprobe.d
  -> Se encontró license.patch
  -> Se encontró semaphore.patch
==> Validando el archivo fuente con sha1sums...
    hybrid-portsrc_x86_32-v5_100_82_111.tar.gz ... Aprobado
    modprobe.d ... Aprobado
    license.patch ... Aprobado
    semaphore.patch ... Aprobado
==> Descomprimiendo fuentes...
  -> Extrayendo hybrid-portsrc_x86_32-v5_100_82_111.tar.gz con bsdtar
==> Iniciando build()...
patching file src/wl/sys/wl_linux.c
Hunk #1 succeeded at 245 (offset 5 lines).
patching file src/wl/sys/wl_iw.h
make: se ingresa al directorio `/usr/src/linux-3.0-ARCH'
make: *** No hay ninguna regla para construir el objetivo `AUR'.  Alto.
make: se sale del directorio `/usr/src/linux-3.0-ARCH'
==> ERROR: Se produjo un error en build().
    Cancelando...

*EDIT: Al parecer todo el problema se origino porque el archivo desde el cual estaba compilando tenía o un nombre muy largo de ruta y/o espacios en la misma.

Gracias aún así por los que pasen a leer
Aprender para compartir

Responder