errores yaourt...

Dudas al crear un paquete? cualquier problema que tengas con makepkg comentalo aca!
goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

errores yaourt...

Mensaje por goro » 12 Abr 2012, 10:19

no puedo instalar nada desde yaourt:

Código: Seleccionar todo

# yaourt -S limoo-git

==> Downloading limoo-git PKGBUILD from AUR...
x PKGBUILD


First Submitted: Thu, 29 Mar 2012 20:37:53 +0000
limoo-git 20120330-1 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> limoo-git dependencies:
 - qt (already installed)
 - cmake (already installed)


==> Continue building limoo-git ? [Y/n]
==> -----------------------------------
==> 
==> Building and installing package
==> WARNING: Building package as root is dangerous.
 Please run yaourt as a non-privileged user.
==> WARNING: Cannot find the git binary required to determine latest git revision.
==> Making package: limoo-git 20120330-1 (Thu Apr 12 07:16:43 CST 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
==> Extracting Sources...
==> Starting build()...
==> Connecting to GIT server...
/var/abs/local/yaourtbuild/limoo-git/./PKGBUILD: line 26: git: command not found
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build limoo-git.
==> Restart building limoo-git ? [y/N]
==> ----------------------------------
==> 
==> WARNING: Following packages have not been installed:
    limoo-git
y asi con diferentes paquetes...en otras palabras tengo de 'adorno' AUR...

Avatar de Usuario
Deckon
Archer Confiable
Archer Confiable
Mensajes: 950
Registrado: 04 Jul 2010, 11:46
Ubicación: México, Estado de México

Re: errores yaourt...

Mensaje por Deckon » 12 Abr 2012, 11:10

bueno el primer error que veo es que usas root para correr yaourt.

el segundo error parece que viene de git perno no lo comprendo muy bien.

el tercero me parece que es debido a un error en el PKGBUILD
GitHub
Linux User #:406092
Arch Linux | XFCE| Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610

Avatar de Usuario
keopety
Archer Intermedio
Archer Intermedio
Mensajes: 96
Registrado: 06 Mar 2012, 07:59
Ubicación: Al final de la cueva y sin mechero

Re: errores yaourt...

Mensaje por keopety » 12 Abr 2012, 11:37

tienes instalado el paquete?
base-devel
si no lo tienes instalalo y cuentas
Imagen
Distro Actual: ArchLinux x86_64 KDE

Todos somos muy ignorantes. Lo que ocurre es que no todos ignoramos las mismas cosas.
(Albert Einstein)

Avatar de Usuario
mcun
Archer Extremo
Archer Extremo
Mensajes: 393
Registrado: 19 May 2010, 11:52
Contactar:

Re: errores yaourt...

Mensaje por mcun » 12 Abr 2012, 13:45

Si te pasa con otros paquetes deberías revisar la wiki para ver que tu configuración sea correcta
Los programadores de verdad no documentan. La documentación es para los idiotas que no pueden leer un volcado de memoria.

Trusted Network and Developer | Debian + TTY | ArchLinux + awesome | openSUSE + Gnome-Shell | Linux User #508809 | @mr_mcun

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: errores yaourt...

Mensaje por madek » 12 Abr 2012, 14:35

/var/abs/local/yaourtbuild/limoo-git/./PKGBUILD: line 26: git: command not found
el problema esta ahi
te falta git

pd: hay que avisar al mantenedor del paquete para que lo agregue como makedepend
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

Re: errores yaourt...

Mensaje por goro » 13 Abr 2012, 00:25

keopety escribió:tienes instalado el paquete?
base-devel
no lo tengo...esperemos sea eso!

goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

Re: errores yaourt...

Mensaje por goro » 13 Abr 2012, 00:28

madek escribió:te falta git
y sin git tira yerro tambien:

Código: Seleccionar todo

$ yaourt -S limoo

==> Downloading limoo PKGBUILD from AUR...
x PKGBUILD


Comment by: Bersam on Wed, 04 Apr 2012 19:24:03 +0000
md5sum should be changed to 3618426a606a19199834be8160025060. == md5sums=('3618426a606a19199834be8160025060')

First Submitted: Thu, 29 Mar 2012 21:07:17 +0000
limoo 0.7-1 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> limoo dependencies:
 - qt (already installed)
 - cmake (already installed)


==> Continue building limoo ? [Y/n]
==> -------------------------------
==> 
==> Building and installing package
==> WARNING: Sudo can not be found. Will use su to acquire root privileges.
==> ERROR: Cannot find the fakeroot binary required for building as non-root user.
==> ERROR: Makepkg was unable to build limoo.
==> Restart building limoo ? [y/N]
==> ------------------------------
==> 
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> 

Please add $EDITOR to your environment variables
for example:                                                                      
export EDITOR="vim" (in ~/.bashrc)
(replace vim with your favorite editor)

==> Edit PKGBUILD with:  

/usr/lib/yaourt/util.sh: line 194: PKGBUILD: command not found
==> limoo dependencies:
 - qt (already installed)
 - cmake (already installed)


==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> Continue building limoo ? [Y/n]
==> -------------------------------
==> 
==> Building and installing package
==> WARNING: Sudo can not be found. Will use su to acquire root privileges.
==> ERROR: Cannot find the fakeroot binary required for building as non-root user.
==> ERROR: Makepkg was unable to build limoo.
==> Restart building limoo ? [y/N]
==> ------------------------------
==> 
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> limoo dependencies:
 - qt (already installed)
 - cmake (already installed)


==> Continue building limoo ? [Y/n]
==> -------------------------------
==> 
==> Building and installing package
==> WARNING: Sudo can not be found. Will use su to acquire root privileges.
==> ERROR: Cannot find the fakeroot binary required for building as non-root user.
==> ERROR: Makepkg was unable to build limoo.
==> Restart building limoo ? [y/N]

Avatar de Usuario
Deckon
Archer Confiable
Archer Confiable
Mensajes: 950
Registrado: 04 Jul 2010, 11:46
Ubicación: México, Estado de México

Re: errores yaourt...

Mensaje por Deckon » 13 Abr 2012, 10:32

te falta fakerrot y sudo y que dejes de usar root...
GitHub
Linux User #:406092
Arch Linux | XFCE| Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610

goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

[solucionado]

Mensaje por goro » 13 Abr 2012, 18:07

resuelto con la instalacion de

Código: Seleccionar todo

make y fakeroot
por cierto no entiendo el recelo por instalar desde yaourt como root...si se instala como usuario al final siempre pide la clave de root(quedamos en lo mismo no?)

Código: Seleccionar todo

sudo
no soy participe de usarlo-no me gusta se me hace sooo Buntus- me quedo con su

Avatar de Usuario
Deckon
Archer Confiable
Archer Confiable
Mensajes: 950
Registrado: 04 Jul 2010, 11:46
Ubicación: México, Estado de México

Re: errores yaourt...

Mensaje por Deckon » 13 Abr 2012, 18:35

supongo que en principio por lo mismo que no usas root en las x's pero igual es solo una recomendación.
Y no no es lo mismo construir e instalar un paquete como root que construirlo como usuario e instalarlo como root
GitHub
Linux User #:406092
Arch Linux | XFCE| Asus P8z77-v | i5-2310 | Nvidia GeForce Gt 610

goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

Re: errores yaourt...

Mensaje por goro » 13 Abr 2012, 18:59

Deckon escribió:no es lo mismo construir e instalar un paquete como root que construirlo como usuario e instalarlo como root
se agradece la explicacion bro!

goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

Re: errores yaourt...

Mensaje por goro » 16 Abr 2012, 18:51

aprovecho para q me ilustren(ensen~en) a 'crear' correctamente un paquete:

Código: Seleccionar todo

# Contributor: Kyle Keen <[email protected]>
pkgname=razor-qt-git
pkgver=20120306
pkgrel=1
pkgdesc="A DE (without wm), at one time based on Anitco."
url="http://razor-qt.sf.net"
arch=('i686' 'x86_64')
license="GPL"
depends=('qt' 'libstatgrab')
optdepends=('openbox: best supported WM'
            'eggwm: also well supported WM'
            '-wm: any WM should work, really')
makedepends=('git' 'cmake')
source=()
md5sums=()

_gitroot="git://github.com/Razor-qt/razor-qt.git"
_gitname="razor-qt"

build() {
  cd "$srcdir"
por ej. cuando pregunta
Edit PKGBUILD ? [Y/n] ("A" to abort)
que es lo q se podria 'editar'?

Avatar de Usuario
madek
Equipo Hispano
Equipo Hispano
Mensajes: 2149
Registrado: 03 Sep 2009, 12:50
Ubicación: Puente Alto, Chile

Re: errores yaourt...

Mensaje por madek » 17 Abr 2012, 12:59

por ejemplo si quieres añadir algun parametro propio a la compilacion o la configuracion del paquete, o para actualizar la md5sum cuando no esta actualizada en el PKGBUILD
Asi hacemos las cosas => The Arch Way
Judd Vinet "Arch Linux es lo que tú haces de él"
Imagen

goro
Archer Avanzado
Archer Avanzado
Mensajes: 142
Registrado: 25 Mar 2012, 18:18

==> ERROR: Cannot find the strip binary required for object

Mensaje por goro » 13 Ago 2012, 01:06

gente: tengo este inconveniente

Código: Seleccionar todo

$ yaourt -S razor-qt

==> Downloading razor-qt PKGBUILD from AUR...
x PKGBUILD
x razorqt041.patch

Comment by: sermonpe on Mon, 07 May 2012 14:59:51 +0000
PKGBUILD modified as recommended by @paddlaren.
Thanks @paddlaren.

Comment by: AyeCapn on Fri, 18 May 2012 15:53:54 +0000
something has gone awry with the patch:


[[email protected](none) razor-qt]$ makepkg -s 
== Making package: razor-qt 0.4.1-3 (Fri May 18 09:51:20 MDT 2012)
== Checking runtime dependencies...
== Checking buildtime dependencies...
== Retrieving Sources...
- Found razorqt-0.4.1.tar.bz2
== ERROR: razorqt041.patch was not found in the build directory and is not a URL.

Comment by: sermonpe on Fri, 18 May 2012 20:30:02 +0000
@AyeCapn I don't know why do you have this problem. I've recompiled it without problems.
Ensure that yo have two files when you unpack razor-qt.tar.gz: PKGBUILD and razorqt041.patch

Comment by: AyeCapn on Sat, 19 May 2012 13:45:06 +0000
Got it! Thanks :) With other packages from AUR I seemed on only need to download the tarball, create the PKGBUILD document and run makepkg. This is the first one I've seen where I had to unpack the tarball first. 

Day 4 of learning Arch Linux - so far a success :D

Comment by: dimik on Wed, 23 May 2012 00:14:40 +0000
@AyeCapn Use yaourt. https://aur.archlinux.org/packages.php?ID=5863 

Comment by: AyeCapn on Wed, 23 May 2012 18:56:13 +0000
@dlink yup - it makes life so much easier. Thanks!

First Submitted: Thu, 09 Jun 2011 11:31:01 +0000
razor-qt 0.4.1-3 
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> razor-qt dependencies:
 - qt (already installed)
 - polkit-qt (already installed)
 - udev (already installed)
 - libxrender (already installed)
 - libxcomposite (already installed)
 - libxdamage (already installed)
 - zlib (already installed)
 - file (already installed)
 - libxcursor (already installed)
 - cmake (already installed)


==> Continue building razor-qt ? [Y/n]
==> ----------------------------------
==> 
==> Building and installing package
==> WARNING: Sudo can not be found. Will use su to acquire root privileges.
==> ERROR: Cannot find the strip binary required for object file stripping.
==> ERROR: Makepkg was unable to build razor-qt.
==> Restart building razor-qt ? [y/N]
==> ---------------------------------
tia!

Avatar de Usuario
cargoan
Archer Confiable
Archer Confiable
Mensajes: 605
Registrado: 13 Mar 2011, 04:39

Re: errores yaourt...

Mensaje por cargoan » 13 Ago 2012, 01:27

¿Has instalado binutils? Parece que no hayas instalado el grupo base-devel completo.
«La simplicidad es la máxima sofisticación» (Leonardo da Vinci)

Responder