Problema con dynamips

Dudas al crear un paquete? cualquier problema que tengas con makepkg comentalo aca!
Responder
Avatar de Usuario
marcostux
Archer
Archer
Mensajes: 24
Registrado: 06 Sep 2012, 11:05
Contactar:

Problema con dynamips

Mensaje por marcostux » 21 Mar 2013, 23:28

Hola saludos a todos, el problema es que necesito usa el simulador de redes gns3 y tiene como dependencia dynamips que hace funcionar las IOS de los router cisco, bien este paquete dynamips me da problema no se compila el error es el siguiente:

Código: Seleccionar todo

==> Compilando e instalando el paquete
==> AVISO: Compilar un paquete como administrador es peligroso.
 Ejecute yaourt como usuario normal.
==> Creando el paquete: dynamips-community 0.2.8RC3-1 (jue mar 21 21:47:41 VET 2013)
==> Resolviendo dependencias...
==> Verificando conflictos...
==> Obteniendo fuentes...
  -> Descargando dynamips-0.2.8-RC3-community.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
100  799k  100  799k    0     0  28720      0  0:00:28  0:00:28 --:--:-- 41953


Validando el archivo fuente con sha1sums...
    dynamips-0.2.8-RC3-community.tar.gz ... Aprobado
==> Descomprimiendo fuentes...
  -> Extrayendo dynamips-0.2.8-RC3-community.tar.gz con bsdtar
==> Iniciando build()...
make -C stable
make[1]: se ingresa al directorio `/tmp/yaourt-tmp-root/aur-dynamips-community/src/dynamips-0.2.8-RC3-community/stable'
Linking rom2c
cc: error: /usr/lib/libelf.a: No existe el fichero o el directorio
make[1]: *** [rom2c] Error 1
make[1]: se sale del directorio `/tmp/yaourt-tmp-root/aur-dynamips-community/src/dynamips-0.2.8-RC3-community/stable'
make: *** [dynamips.stable] Error 2
==> ERROR: Se produjo un error en build().
    Cancelando...
tw: @marcostux

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1774
Registrado: 18 Nov 2010, 23:33
Ubicación: Behind your computer

Re: Problema con dynamips

Mensaje por Spooky » 21 Mar 2013, 23:51

El paquete esta desactualizado, lo mejor es que bajes el código de fuente directo del sitio oficial y compiles tu mismo.
Luego los comentarios de los usuarios dicen que instalando elfutils se resuelve ese error.

PD: tema movido al foro correcto.

Avatar de Usuario
cuentos
Equipo Hispano
Equipo Hispano
Mensajes: 544
Registrado: 25 Mar 2012, 03:24
Contactar:

Re: Problema con dynamips

Mensaje por cuentos » 22 Mar 2013, 02:02

Y mira bien la primera parte:
==> Compilando e instalando el paquete
==> AVISO: Compilar un paquete como administrador es peligroso.
No utilices sudo en yaourt.
twitter @mcuentos

Responder