[ Solucionado ] instalar google-chrome, archivos deb y rpm

Dudas al crear un paquete? cualquier problema que tengas con makepkg comentalo aca!
Responder
haular
Novato
Mensajes: 12
Registrado: 26 Jun 2013, 22:01

[ Solucionado ] instalar google-chrome, archivos deb y rpm

Mensaje por haular » 27 Jun 2013, 21:20

Buenas Usuarios de Arch tengo un gran problema con pacman soy nuevo en esto y no e podido instalar google-chrome-stable ya probe por pacman y me dice que los archivos estan danados igual pasa por yaourt, descargue los repositorios mediante la pagina de arch linux pero no se como instalarlo no veo el archivo PKGBUILD .... este es el archivo que descargue google-chrome-stable_28.0.1500.63_i386.deb pero no se como instalarlo.

Agradeceria no colocar respuesta como descarga chromium porfavor.
Última edición por haular el 02 Jul 2013, 15:42, editado 1 vez en total.

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1774
Registrado: 18 Nov 2010, 23:33
Ubicación: Behind your computer

Re: Problemas para instalar google-chrome, archivos deb y rp

Mensaje por Spooky » 27 Jun 2013, 21:54

Los PKGBUILDs de AUR se instalan usando algún helper:
https://wiki.archlinux.org/index.php/AUR_Helpers
Tambien puedes instalar el PKGBUILD manualmente, para ello te bajas el tarball de AUR:
https://aur.archlinux.org/packages/goog ... setlang=es

Descomprimes el archivo y desde una consola te diriges al directorio que se creo al descomprimir el archivo.
Luego haces un:

Código: Seleccionar todo

makepkg -S
Finalmente con pacman instalas el paquete, este debería tener una extensión .pkg.tar.xz:

Código: Seleccionar todo

pacman -U el_paquete.pkg.tar.xz

haular
Novato
Mensajes: 12
Registrado: 26 Jun 2013, 22:01

Re: Problemas para instalar google-chrome, archivos deb y rp

Mensaje por haular » 28 Jun 2013, 00:12

listo con esa parte pero ahora al aplicar pacman -U google-chrome-28.0.1500.63-1.src.tar.gz me sucede lo que me a estado pasando

error: faltan los metadatos del paquete en google-chrome-28.0.1500.63-1.src.tar.gz
error: 'google-chrome-28.0.1500.63-1.src.tar.gz': paquete no válido o dañado

eso :?

Avatar de Usuario
cuentos
Equipo Hispano
Equipo Hispano
Mensajes: 544
Registrado: 25 Mar 2012, 03:24
Contactar:

Re: Problemas para instalar google-chrome, archivos deb y rp

Mensaje por cuentos » 28 Jun 2013, 00:19

Prueba con yaourt, instala chromium (prefiero este que es open, o si prefiere crhome)

Código: Seleccionar todo

yaourt -S chromium
Para la llave GPT que suele dar problemas. Mira aquí.
http://foros.archlinux-es.org/viewtopic.php?f=5&t=7095
twitter @mcuentos

Avatar de Usuario
cargoan
Archer Confiable
Archer Confiable
Mensajes: 605
Registrado: 13 Mar 2011, 04:39

Re: Problemas para instalar google-chrome, archivos deb y rp

Mensaje por cargoan » 02 Jul 2013, 06:08

haular escribió:listo con esa parte pero ahora al aplicar pacman -U google-chrome-28.0.1500.63-1.src.tar.gz me sucede lo que me a estado pasando

error: faltan los metadatos del paquete en google-chrome-28.0.1500.63-1.src.tar.gz
error: 'google-chrome-28.0.1500.63-1.src.tar.gz': paquete no válido o dañado

eso :?
como dijo Spooky es .pkg.tar.xz
Spooky escribió:...
Finalmente con pacman instalas el paquete, este debería tener una extensión .pkg.tar.xz:

Código: Seleccionar todo

pacman -U el_paquete.pkg.tar.xz
«La simplicidad es la máxima sofisticación» (Leonardo da Vinci)

haular
Novato
Mensajes: 12
Registrado: 26 Jun 2013, 22:01

Re: Problemas para instalar google-chrome, archivos deb y rp

Mensaje por haular » 02 Jul 2013, 08:46

tenias razon cargoan seleccione paquete equivocado :D ya esta todo listo muchas gracias ... disculpa Spooky no preste atencion a la extension del archivo.

Avatar de Usuario
Spooky
Equipo Hispano
Equipo Hispano
Mensajes: 1774
Registrado: 18 Nov 2010, 23:33
Ubicación: Behind your computer

Re: Problemas para instalar google-chrome, archivos deb y rp

Mensaje por Spooky » 02 Jul 2013, 11:24

Si consideras que solucionste el tema, favor de editar el primer post y marcar como [Solucionado].

Saludos

Responder