Errores al compilar Owncloud [Solucionado]

Dudas al crear un paquete? cualquier problema que tengas con makepkg comentalo aca!
Responder
zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Errores al compilar Owncloud [Solucionado]

Mensaje por zx81 » 07 Sep 2014, 06:53

Hola foro.

Estoy tratando de instalar owncloud-client desde yaourt y me da el siguiente error de compilación:

Código: Seleccionar todo

Traceback (most recent call last):
  File "/usr/bin/sphinx-build", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2872, in <module>
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 449, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 745, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 639, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: Sphinx==1.2.2
doc/CMakeFiles/doc-man.dir/build.make:49: recipe for target 'doc/CMakeFiles/doc-man' failed
make[3]: *** [doc/CMakeFiles/doc-man] Error 1
CMakeFiles/Makefile2:785: recipe for target 'doc/CMakeFiles/doc-man.dir/all' failed
make[2]: *** [doc/CMakeFiles/doc-man.dir/all] Error 2
CMakeFiles/Makefile2:793: recipe for target 'doc/CMakeFiles/doc-man.dir/rule' failed
make[1]: *** [doc/CMakeFiles/doc-man.dir/rule] Error 2
Makefile:405: recipe for target 'doc-man' failed
make: *** [doc-man] Error 2
==> ERROR: Se produjo un error en build().
    Cancelando...
==> ERROR: Makepkg no ha podido compilar owncloud-client.
No entiendo de compilaciones, pero el error parece que está en doc-man, que no lo encuentra. He buscado por la red y no he encontrado nada que me solucione el error, a ver si me podéis echar un cable. Gracias.

Avatar de Usuario
snkisuke
Archer Intermedio
Archer Intermedio
Mensajes: 72
Registrado: 03 Jun 2012, 11:34
Ubicación: human- infested Buenos Aires

Re: ERROR OWNCLOUD

Mensaje por snkisuke » 07 Sep 2014, 12:16

segun lo que leo tu error es debido a que te falta una dependencia llamada python-sphinx si estas usando python3 o python2-sphinx si estas usando python2 instala eso y ya deberia poder continuar tu instalacion
Sí, no tenemos destino. Sólo aquellos consumidos por la ignorancia y el miedo que dan pasos en falso pueden hundirse en las turbias aguas llamadas "Destino".

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: ERROR OWNCLOUD

Mensaje por zx81 » 09 Sep 2014, 05:03

Gracias por la respuesta, pero tengo ambos python-sphinx instalados y el error persiste.

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

[SOLVENTADO] Re: ERROR OWNCLOUD

Mensaje por zx81 » 09 Sep 2014, 05:16

Snkisuke, me has dado una pista, y es que tengo una impresora HP y de muchos es sabido la incompatibilidad del plugin hplip con python3, así que modifiqué en su día el enlace simbolico que apunta a python3 ( /usr/bin/python ) para que apuntara a python2.7.

He reapuntado otra vez a python3 y ha funcionado. Gracias de nuevo.

Avatar de Usuario
snkisuke
Archer Intermedio
Archer Intermedio
Mensajes: 72
Registrado: 03 Jun 2012, 11:34
Ubicación: human- infested Buenos Aires

Re: ERROR OWNCLOUD

Mensaje por snkisuke » 09 Sep 2014, 10:50

De nada, me alegro que llegaras a la solucion.
Sí, no tenemos destino. Sólo aquellos consumidos por la ignorancia y el miedo que dan pasos en falso pueden hundirse en las turbias aguas llamadas "Destino".

Responder