Haciendo un downgrade

Dudas al crear un paquete? cualquier problema que tengas con makepkg comentalo aca!
Responder
Avatar de Usuario
Jacobo2014
Archer Intermedio
Archer Intermedio
Mensajes: 68
Registrado: 30 Oct 2014, 06:24

Haciendo un downgrade

Mensaje por Jacobo2014 » 10 Mar 2015, 14:07

Hola, me gustaría jugar al Mame pero las Roms que tengo corresponden a la versión 0.139-1 actualmente va por la 0.159-1 por lo que estoy intentando hacer un downgrade pero no sé como hacerlo.

Me he descargado el paquete de aquí:

https://projects.archlinux.org/svntogit ... c7d8c6cb58

Y lo he descomprimido en mi carpeta home. Cambio a ~/community-d08e98a6192134a5c0fa495f9d9eeaaf0118b68b/repos/community-x86_64 ya que mi equipo es 64 bit y allí ejecuto "makepkg" pero me da los siguientes errores:

Código: Seleccionar todo

$ makepkg
==> ERROR: La matriz options contiene una opción desconocida: «force»
==> ERROR: Falta la función package() en ~/community-d2906dcc2276f774ea3ac9616fab05c7d8c6cb58/repos/community-x86_64/PKGBUILD

Realmente no sé lo que estoy haciendo ni si eso es así o no.

¿Alguien me puede echar un cable?

Gracias.
La experiencia me ha enseñado que la mejor forma de protegerse es hacer creer a tus enemigos que no pueden hacerte daño.

zx81
Archer Extremo
Archer Extremo
Mensajes: 193
Registrado: 13 Ago 2012, 16:22

Re: Haciendo un downgrade

Mensaje por zx81 » 24 Mar 2015, 07:25

No es necesario actualizar o hacer downgrade para poder jugar. Las ROMS funcionan en todas las versiones, solo necesitas unos archivos "bios" para hacerlas compatibles. Yo he jugado años y habían juegos a los que ya no podía jugar, hasta que leí lo de las bios, que descargaba de webs de emulación, y listo.

Responder